Sublime Forum

[Solved] Disable "Update Available" pop up?

#1

I have version 2 Alpha.

How can I disable “Update Available”, “A new version of Sublime Text 2 is available, download now?” pop up?
Since I do not want to upgrade as often as new build comes out. Pop up is annoying.

1 Like

Disable "A new version of Sublime Text is available, download now?" in Sublime 3 (stable channel)
Where is the disable update notifications option...?
How do I disable update checks?
#2

Firstly, you may want to check that you’re using a regular version from sublimetext.com/dev. The regular version gets weekly updates, while the dev version often gets daily updates.

There will be a way to stop update notifications when the final version of Sublime Text 2 is released, but it’s not high on my priority list to implement for the alpha versions.

1 Like

#3

I am using 2051 and all of a sudden, this week, it started giving me the “update available” message whenever I start. :confused: I check the site but there don’t seem to be new alpha builds (other than dev builds)?

1 Like

#4

The current build is 2059:

sublimetext.com/2

The “dev channel” builds are listed here:

sublimetext.com/dev

There might have been some connectivity issues (proxy?) and that’s why you didn’t get more notifications?

1 Like

#5

Thanks… wow… even when I clicked your link it came up with 2051… I hit the browser refresh and it updated properly to show 2059. Some serious browser caching was going on. :confused:

1 Like

#6

Just go to Preferences -> Settings-User and add there: “update_check”: false,

4 Likes

Preventing dialog box prompting to update to new version
#7

I was puzzled at first. Thank you for sharing this!

1 Like

#8

This is now working for me, has there been any change?

1 Like

#10

This solution didn’t work for me. The pop up is very annoying. I don’t even want the program to check for updates every time I use it. Also downloading a new version doesn’t solve the problem. I get error code 32, “unable to rename”, even running as admin.

1 Like

#11

Thank you… worked perfectly for me. Using build 3083 atm.

For those who didn’t get this to work… If you added this to the bottom of the list of setting (aka, it’s the** LAST rule OR the only rule**) you need to omit the comma at the end of the line. Or just add it in at the top and leave the comma alone.

1 Like

#12

Did not work for me, currently using (unregistered) stable channel build 3103. I wonder if one needs to make this change, but still download and install the new version, before the prompt will go away.

The entirety of my Preferences.sublime-settings file:

1 Like

#13

1 Like

#14
2 Likes

#15

Can this thread have the “[SOLVED]” flag removed from the title, since the solution apparently has been removed?

See also Preventing dialog box prompting to update to new version

0 Likes

#16

The solution is referenced in @kingkeith’s last post: It only works if your copy is registered.

1 Like

#18

Wow! It’s now working for me. Thank you for sharing.

1 Like

#19

In case anyone was wondering how do it in Sublime Text 3:

{
“ignored_packages”:
[
“Vintage”
], //Only add coma after this bracket
“update_check”: false //And add this line inside the curly brackets
}

That’s it!

1 Like

#20

That only works with dev builds. The other method works, but then you can’t access the main Sublime Text website at all.

1 Like

#21


Thank you.

1 Like

#24

For those of us who did update by mistake, it would be nice to provide links to earlier versions. At least for version 3126, that still had a proper UI. Now you have to guess the download link, and type it in manually, and then edit the preferences on every single installation to get rid of the update message.

0 Likes