Sublime Forum

No Package Control after updating to Sublime Text 4?


So, excited as I was, I installed Sublime Text 4 on a machine that some time ago had Sublime Text 3 installed, and… I just can’t wrap my head around how I’m to install Package Control.

Now, in my command palette I have Preferences: Package Control Settings, and that’s it. I can’t neither open or install it. What do I do?

1 Like


Sounds like you have it installed already.



Yeah well uh, I’d love to be able to use it then :grimacing:

I don’t remember what the folder structure used to be, but now I do have some files in Packages/User, like Package Control.last-run, Package Control.merged-ca-bundle, Package Control.sublime-settings, but I can’t open Package Control from inside of Sublime Text.

I should probably add that I’m using Mac



When you open the Command Palette, there should be an entry called “Package Control: Install Package”. Is that entry not present?



It’s not. Anyways, I fixed it by deleting system cache files for Sublime and re-installing it

1 Like


I have the same issue on my Ubuntu system.
On the first start after upgrading to ST4 there was warning message that LSP plugin is not supported and should be deleted and reinstalled. So I went to command palette and tried to search for package control - nothing found.
I definitely have package control installed and it worked in ST3.
Any clues how can I delete LSP manually? (Package Control is absent in command palette).


From ST3 to ST, copied user folder, only partial recognition by ST(4)

Have you checked your ignored_packages setting to see if Package Control is not accidentally ignored ?



Thank you. Package Control was in ignored packages list. But I didn’t put it there. Looks like it was added to ignored packages by ST4 installation.

1 Like


ST4 doesn’t mess with packages. There was a bug at some point with package control that could cause that though iirc



It’s a known issue Package Control to put itself into ignored_packages sometimes. Several changes were made to avoid it, but it seems to still happen occationally. It is mainly caused by the way dependencies are handled, which should be fixed with PC 4.0 which is under development.



I also had some issues after upgrading to ST4, and went for a fresh start: Renamed the old ST3 config folder to ~/.config/sublime-text-3 to be able to reference my old settings, let ST4 create a fresh ~/.config/sublime-text and re-installed Package Control, and packages.

The only problem I have found so far is the awesome Compare Side-By-Side open up the two tabs in the right hand side …



Re: it’s a known… known what? In summary, “issue” is a profound understatement of corporate coding’s subscription distraction, to collect baby allowance for buttery MIT suction cups. Cute! Aside from distraction, Sublime 4’s only significant enhancement over 3 is the developer price grab. Hungering for another version 1-2 punch-up here [hurt]. Not that driving slicker code wheels to their suction depot necessarily improves GRUNT ST Coding, above and beyond what it is, 2 decades and counting of solid performance. Will they use their new millions to finally WYSIWYG? Or, is the grab specialized, squander to further Elite Baby Care programs, like MIT? Screw the masses! Taxing communication is the New Suction Depot policy. “Suck with us,” or suffer worsening distraction? America is suffocating to death, Sublimely!

Sublime cost 1991-2021 $ 300 - projected 2021-2041 $ 2,000 - SNAPSHOT

Query, did Europeans suffer the same crash, or did my Google faithfully portray it as another colonial kick-in-the-face? Why us again? How can we secure Sublime’s colonial coding environment? That’s my wonder, having witnessed 4107 crashing critical Package Control infrastructure, while France-Spain-Germany chortled in glee. Diabolical greed shammed as a scam, literally taxing living communication. Sublime crash recovery imprinted forever, parallel to Covid culture’s vaccine addiction. Pricing scam that offers us no relief, taxing our children’s communication with Subscription Boosters. Pray they survive to enjoy what is Sublime, regardless. Technocracy is a massive technical issue. Something like an Atom-Sublime parallel cross-platform venue would serve us well. Put a check on flourishing greed, if properly regulated.



That’s an improvement from my mac’s perspective… gave up wondering when SxS would ever work again. Assuming you got Package Control to [apparently] install SxS. Can your ST4 drag-and-drop the 2 S’s side-by-side in a new window?

Here, ST4’s PC was never ignored, but it never installs anything except maybe itself. Window dressing looks good and License 4 works, otherwise staying with ST3 for now. You got something working there, regas. Hooray!



If you pay for Sublime Text, you are paying for support.



There is a MR which fixes it, see Compare Side-By-Side for ST4?



And when I write support I mean to support financially the developers that work on the text editor so that you can get technical support in Sublime Text. This excludes plugins, since they are not a core part of the ST. They are made by third-parties.

So for a fix to your plugin, you will need either community or the plugin author to step up. Luckily, there is a fix already for Compare Side By Side.



There’s a lot of activity in this conversation, but I don’t think I picked up what the recommended non-nuclear solution is. If there’s ignored_packages what should be done? Is the only solution to nuke SLT cache? I appear to be bitten by this bug on 2x different machines so this is most certainly triggered by the update to SLT4 from 3.



If your issue is that Package Control doesn’t seem to be there when it was before the upgrade:

  1. Preferences > Settings, check the pane on the right. Do you see Package Control or 0_package_control_loader in the list? If yes, remove them from the list.

  2. Preferences > Browse Packages, then in the window that opens, go up one level and into the folder named Installed Packages; do you see Package Control.sublime-package in the list? If not, then something may have removed it (though not the update; it leaves this folder alone). In that case, reinstalling Package Control would solve the problem.

The general problem you see with Package Control seemingly going missing is the fact that when Package Control updates any package (including itself) it has to add them to the list of ignored packages so that Sublime will unload the package, or on some OS’s the old file can’t be moved away.

If you restart Sublime in the middle of such an upgrade, when Sublime restarts Package Control is in the list of ignored packages, isn’t loaded, and thus can’t finish the upgrade. Removing it from the list of ignored packages clears the situation.

That’s not related to an update of Sublime Text in any way other than when Sublime upgrades itself it involves the process restarting, so if you happen to upgrade Sublime while PC is upgrading packages, things can potentially go sideways.

As such, that can potentially happen any time Sublime upgrades itself, and the fact that it happens to have happened on an upgrade that carried someone over to the new version is effectively a red herring if anyone is looking to finger something for blame reasons.



I can’t really understand a lot of the word salad, but it comes across you are upset about the price. For me the cost went from about an initial $70 in like 2017 or so to $80 add’l if I want to upgrade.

You can use other software. Its OK.

In all seriousness, hope you find a constructive outlet for your own sake.



Read your link, thanks. Perhaps C-SBS is maintained for ST2. Regardless, try using raw ST, no packages, just latest and Monokai greatest… Yesterday, ST3 without installed packages was doing half-second SBS flashes. Clearly, the ST Net 4 devo teams are doing something with SBS.

Any thoughts on that?