Sublime Forum

Sublime Desktop Icon and Projects

#1

Hi
I’ve been using Sublime for a few months to do a project in a learning language (Jack) and now want to write something in C and thought this would be a good time to learn to use the project feature.

In this video


(OhDatNurd I tried looking for something on your channel !)

it says that you can just grab and drop a folder onto the Sublime icon and voila instant project; except when I installed ST3 there was a problem installing this icon (?) (Probably my bad) and so I only have a link to ST3, hence the dragging of a folder on to it doesn’t work.
Any ideas how to fix so that I can “get into” the projects feature ?
Am running linux 17.1 MATE

Thank you
Lozminda

Ps Also (this is prob a separate question) but what’s the point of building using ST3 (am thinking about my C programs) it looks real complicated and if it isn’t could someone point me in the direction of some good tutorials pls ?

0 Likes

Where is the tab title/sidebar font defined in Ubuntu?
#2

I can’t help with that specifically (although I use Sublime on Linux, I don’t use that distribution and I also generally don’t use drag and drop in general) but that’s not the only way to add folders to a project.

You can also use the File > Open Folder... and Project > Add Folder to Project... menu items to accomplish the same task, and if you already have a window open you can drop a folder onto the window to add it as well.

Generally the idea is that you can work and iterate faster on your code if, when you’re done with changes you only need to press a single key in order to compile your program (and maybe run it as well), as opposed to saving your code, then jumping to a console window and compiling it there. What is best is really what helps you work your best though; whichever way you decide to do it, as long as you’re comfortable with it and it’s working for you, that’s probably the best way.

Note that the general complication is related to building C/C++ programs in general though, and not directly related to how you would do it in Sublime. They’re languages that are more complicated from the perspective of having to run potentially multiple commands in order to get your program compiled and running.

In that regard, the best tutorials to go for would be ones that are trying to show you how to compile and run your programs, and not what magic buttons and checkboxes you use in any particular editor/IDE in order to get it to do that part for you.

If you know how to compile your code manually from the command line, then you can easily automate it in Sublime if desired.

There is indeed a video related to the topic of Projects and Workspaces. It covers the items mentioned above related to the various ways to open folders, though it doesn’t cover the drag and drop approach which is probably a bit of an oversight on my part.

0 Likes

#3

OdatNurd, sorry I spelt your name incorrectly !
Thanks for yet another excellent reply.
Amazing, I spent a good 15 mins rooting through your channel and missed it, Doh !
Weirdly I couldn’t get the open project to work (in the way you suggested) which has been one of the things that’s been putting me off utilising that function, but I’ll have another go (the drag and drop deffo don’t work)

It would be nice to have the correct Sublime icon and functionality if anyone else could help me, but I’ve got some stuff to be going on with atm !

Thanks again
Lozminda

0 Likes

#4

Some of the older videos don’t have very descriptive titles (I’m slowly going through and fixing that sort of thing) so I’m not entirely surprised by that. Hopefully it will be much better soon. :slight_smile:

It’s interesting that dragging and dropping into the window directly also doesn’t work; that works for me. That might be something distro or setup specific that’s blocking things or something.

0 Likes

#5

I don’t have the sublime icon, just a link to sublime, I’m guessing there’s something in the icon functionality. The link is just a link to executable. OdatNurd, I do have a suggestion for your channel (if interested), I’ve subscribed, I’m guessing this Isn’t the correct place to make that suggestion? what’s the best way to comment on your material ?

Cheers, Lminda

0 Likes

#6

There’s a Discussion tab on the channel where you can make public comments/requests/etc, and you can also tweet at me as well. If you don’t want to be public about it, a twitter DM or a message on the forum is OK too.

0 Likes

#7

You can start a project by dropping the folder on the icon, on the Sublime window, or File > Open Folder... as @OdatNurd has already pointed out. Make sure the sidebar is enabled under View > Side Bar as dropping on the window won’t open another window.

There are some weirdness on Linux though because of the way the file manager is coded. For example, I have Thunar as file manager and I can drag and drop folders from the main view, but I can’t from the location bar.

And if you need a working desktop file here’s my sublime-text.desktop (put it under /usr/share/applications):

[Desktop Entry]
Version=1.0
Type=Application
Name=Sublime Text
GenericName=Text Editor
Comment=Sophisticated text editor for code, markup and prose
Exec=/opt/sublime_text/sublime_text %F
Terminal=false
MimeType=text/plain;
Icon=sublime-text
Categories=TextEditor;Development;
StartupNotify=true
Actions=Window;Document;

[Desktop Action Window]
Name=New Window
Exec=/opt/sublime_text/sublime_text -n
OnlyShowIn=Unity;

[Desktop Action Document]
Name=New File
Exec=/opt/sublime_text/sublime_text --command new_file
OnlyShowIn=Unity;
1 Like

#8

@An_dz
Unfortunately your fix for my desktop icon doesn’t work.
There’s a sublime-text icon in my Applications drop-down menu, it doesn’t work. If I drag it onto the desktop (like can be done with any other launcher, so there’s a large icon on the desktop), it gives me an icon, but it won’t launch anything.
I though the problem might be the OnlyShownIn=Unity as I’m running Mint MATE, tried deleting that line , but to no avail. If you (or anyone else has a fix) that’d be fantastic.

Now the corona virus is keeping me indoors (hope y’all ok, everyone) I have sometime to work on projects and ST3.

@OdatNurd thanks for everything re Projects.

To the forum: Unfortunately having started up a project (well had a fiddle) I ran into my next issue. The font in the SideBar is huge (I usually run a font.size of 7, I have a large-ish screen, so am trying to get as much well-spaced info on the screen as possible).

I followed the advice here:


which gave me a default theme, which kept everything the same size but reversed the colours. Maybe it did nothing, as I can’t get that origional behaviour back.

At this point I have Adaptive and Default sublime themes BTW

The Adaptive is light font on dark background (:smiley:) the Default is dark font on light (:face_vomiting:)

I tried changing the text size in the Adaptive theme’s font sizes, saved, restarted, repeated no change.

I thought I’d copy everything in Adaptive into Default, that worked and I no have much smaller font size (woo hoo !) but the colour scheme is all wrong (I have dark text on a light background)

How can I have small font size on my side bar (etc) but light on dark text pls.

I’ve been working on this for a good hour and got nowhere, so any help much appreciated.

Hope everyone’s not going crazy on lock down !

Lozminda

0 Likes

#9

If you have the PackageDev package installed, you can choose PackageDev: Edit Current Theme. You will get a split layout window. The one on the left is the Default theme & one on the right is where you can have your custom stuff. For changing the font size of the side bar, search for the sidebar_label class on the left side & copy that entire object to the the rules array on the right side. It should have a font.size property. Change that to your preference. As far as I can tell, that shouldn’t mess with anything else.

0 Likes

#10

@UltraInstinct05 Excellent, thank you. What would I copy to make everything smaller? Indentation, the “FOLDERS” and “OPENFILES” titles too.
Then I can get a bit more screen size.

Great answer !

0 Likes

#11

I thought I’d copy everything in Adaptive into Default, that worked and I no have much smaller font size (woo hoo !) but the colour scheme is all wrong (I have dark text on a light background)

Similar weirdness for me. But one-time only. Other than you but my data got tangled too. After that ‘Adaptive-Default’ copy-works-one-time-only weirdness, did erase, reinstall OS and ST then worked fine: i.e., data tangles gone.

No idea, feels like a ‘user’ / ‘system resource’ / ‘OS-user account’ thing and only ST settles down this way. That might be because ST builds the OS somewhere somehow something (s). Buggy.

0 Likes

#12

@mark.stewart.
Hi, @UltraInstinct05 's advice has worked fine, so far no conflicts.

To anyone this maybe useful for:
Following @UltraInstinct05 's template, I copied everything over that had font.size in it over and reduced their values. Also I copied
{
“class”: “sidebar_tree”,
“row_padding”: [16, 3, 4, 3],
“indent”: 4,
“indent_offset”: 5,
“indent_top_level”: false,
“dark_content”: true,
“spacer_rows”: true
},
over too and reduced the indents, so I now have a ‘compact theme’ as it were surrounding my text editor. Excellent!

Again thanks to all. I’ll put this as solved and repost the icon problem as a separate as that hasn’t been solved.
Lozminda

0 Likes

Broken ST3 Icon