Sublime Forum

ST3 crashes frequently since Build 3124


@wbond thanks for the reply! I am already using the old version, I will keep around just to help test if it’s needed. Cheers!



Which dev build version is working for you?



I have stable version wokring as below, dev version, just tested the one you post it here, 3125 which is not working.

Stable versions working fine are:

  1. 3114 (regularinstalation)
  2. 3124 (portable)
  3. 3124 (installed under root drive c: (windows)


Here are some other versions of Windows x64 if anyone wants to take the time to see if a specific build is when the issue started (installing within Program Files):

1 Like


After updating to 3124, I wasn’t able to start it anymore, unless I do it with admin privileges. Although when I use admin privileges, I have trouble accessing files outside of C:.
I’ve also tried other versions, but none of them will work. It ends up crashing after placing the mouse over the window, no matter which version I’m using.



It looks like a problem on the Sublime Text Updater, which is not setting the new files permissions correctly. So, to solve this problem, do not use the auto-updater. Manually download the portable version, go to C:\Program Files\Sublime Text 3\, backup and delete everything, unzip the portable version contents there, and delete its ‘Sublime Text 3\Data’ folder after it. Now you are done, and your Sublime Text is manually updated.

While doing this, the Windows will complain about file access permission, then click on request access and continue.



This isn’t universally true. I’ve tried to reproduce the error by using the updater to upgrade from 3114 to 3124 and everything seems to run fine.

Can anyone who is having trouble with this error confirm that wiping the folder C:\Program Files\Sublime Text 3\ solves the issue for them?



I did this and other similar tries many times - none of them resulted in success.
I have tried uninstalling, reinstalling, cleaning user data, but nothing resulted in having it working.
It doesn’t seem to be a files permission problem, as Sublime crashes only after moving the mouse over it on a non-admin session.



It did not solved the issue for me…



Could you perhaps try a couple of the dev builds I linked to and see if any of them work? I’m trying to determine when during the past few months of development this bug may have been introduced.



I could not understand correctly. What is a non-admin session? Could you show all packages you got installed?

May you reproduce it (the crash) on a vanilla install?



If I run Sublime Text with admin privileges, it works fine, but if I run it without admin privileges, it freezes as soon as I place the mouse over its window, as on the attached screenshot.



Tried with 3116 and 3114 - both failed.

I’ve also tried older installers, but all of them ended up crashing after placing the mouse over the window.

It’s weird that any version now produces the same result, but it only started to behave this way after updating to 3114 this morning. Prior to the update, it was working without a problem.

1 Like


Can you ensure you’ve moved %APPDATA%\Roaming\Sublime Text 3\ to ensure there isn’t some sort of bad permissions or corrupt files in there?

Alternatively you can use the Portable version since it is self-contained.



I tried deleting both “%APPDATA%\Sublime Text 3” and “%LOCALAPPDATA%\Sublime Text 3”.

Portable version behaves the same way. Running with admin privileges makes it work, but it looks like it doesn’t fully interact with the OS, as I’m not able to drag and drop files to open them, nor access my network drives.
Running Portable without admin privileges ends up on a new crash/freeze after moving the mouse over its screen.



Which one is your windows 10 build? Is it x86 or x64? And your sublime version, is x86 or x64?



Windows 10 Pro
Version 1607
OS Build 14393.187
Both Windows and Sublime x64



I just tried the x86 portable version and it worked without any problem.
It seems to be the only version working in here.



So, the portable x86 version is working correctly without any problems.

You tried to install the x86 version? To make your x86 portable version, a normal version, just close Sublime Text, and rename the Data folder, inside your portable folder, to something as Dataa, and open Sublime Text. After that, the issue persists? Even if you renamed/removed all the native folders as:
%APPDATA%\Roaming\Sublime Text 3
%APPDATA%\Local\Sublime Text 3\

1 Like


Installing the x86 version made it work too.
The issues happen only with the x64 version.
Both portable and installed x86 versions worked.


Windows 10 - Sublime 3 open and freezes