Sublime Forum

Keyboard shortcuts with regional keyboard


Im trying to use SublimeText more effective way, but while using regional keyboard i cant get to work any common shortcut. Is there some plugin or setup to make Sublime think im using EN layout but stick with my letters? Or Sublime doesnt support other languages/kb layouts than EN?

Thanks for making me sure or tip how to fix it.


Keybinding for shortcut is wrong with different keyboard mapping

a related/similar post, albeit with no advice yet



maybe you can provide more information, that might help someone come up with a solution :slightly_smiling:

which keyboard layout are you using? if you enable input logging (View menu -> Show Console -> type sublime.log_input(True)) and then try some keyboard shortcuts, what gets displayed, compared to what you press?


Ubuntu Shortcuts

I dont think my keyboard sends other letter i press. Try to look at any other regional kb layouts than EN and easilly find that you need to press, for example, SHIFT to write numbers or ALT to write “~” aso… this modifies shortcut and it doesnt work or starts other action. Same problem must have many other languages, not just mine, but looks like noone cares about shortcuts and main audience is EN speaking.




There is a similar issue in Atom editor, where the default layout for shortcut is indeed an american layout and no shortcut works. Nobody cares and developpers can’t even make fully working plugin to solve this issue as Chromium (which Atom and Electron rely on) keyboards event are bugged, that’s what pushed me to give a try to Sublime.

Here the case looks different, as symbols seems to be well detected on my French azerty keyboard with Ubuntu (one can take a look at it using the console and log_input as specified before), but some stuffs does not work, especially when using shift or maj as I said in my post on the technical support form.

I hope the case will be taken more seriously by Sublime developpers than by Atom devs, not all developpers are American mac users but all of them need a decent, quick and cross-platform editor…



ATOM has working solution. But strange is, that Apple, Microsoft or any other producer doesnt have any solution. Yes, most users are Mac EN, but the rest is not so small. I hope some day there will be at least third party plugin.



Same problem here…lot of shortcuts does not work which makes one very unproductive. :frowning:

E.g. to toggle comment, shortcut is Ctrl+/.

and in order to enter it on m Croatian (HR) keyboard, I’ve to press:


which I do as seen from the input log:

key evt: shift+control+7

So, it would be very much appreciated if ST dev(s) could find a proper fix for non-En users.

Any info in regard?

Edit: Well, for now I just followed someone’s advice and changed keybinding to Ctrl+(Shift+)+7 which is good-enough until proper fix does happen which makes ST3 still better than Atom which still has issues with it. :slightly_smiling:


Key input not handled correctly

I’m on a French Azerty keyboard, and I remapped most of the default keybindings to work on it.
It’s a bit tedious, since Windows and Linux doesn’t receive the same input.

Maybe I should create a Package Control package for overriding default keymap with something that works on Azerty…



But there will still be a problem with shortcuts like “ctrl+[” mapping to “unindent” that will collide with “ctrl+5” mapping to “focus_group 4”, since [ and 5 are on the same key.

Same thing for “ctrl+`” mapping to “show_panel console” and “ctrl+7” mapping to “focus_group 6”.

So a little bit of design seems necessary. Shall we try to align key bindings with the same description: (so if a user reads “type ctrl+`” to open the console he will easily find it), or use the “²” key left to the 1 key so the position on keyboard is the same ?



I’m using a French keyboard on my mac, and the only solution I’ve found was adding the US keyboard as keyboard input source. Ive still not worked out how to do ctrl space though (select next auto complete suggestion) as that gives combo gives no input at all.



Here is my solution video on Youtube (unfortunately in Turkish Language):

TLDR (Too Long Didn’t Read ) Section:

  1. Open View > Sublime Text Console
  2. Write this type sublime.log_input(True)
  3. See your keylogs on console
  4. Open your Preferences>Key Bindings
  5. Change your comment key bindings from Ctrl + / to Ctrl + keypad_divide