Sublime Forum

SublimeText 4 Install Package not showing the menu


Hi there!
I’m using SublimeText v4 build 4152 (update 02/08/2023).

I successfully installed the Package Control, but when I try to install a package SublimeText doesn’t show the command Package Control: Install Package (see figs)

Here are the steps I tried:

  1. Open the Command Palette using shift+command+p (OS X) or by selecting Tools > Command Palette from the menu bar;
  2. Find and select the command Package Control: Install Package.
  3. No results

Any suggestions?


If you are encountering this problem, the proper solution is to install the 4.0 beta version as described in the issue linked below by @deathaxe. Other solutions can and will compromise the security of your machine,


Can not install packages with package control

Duplicate of

Mainly tracked at

Also reported at


No Package Control after updating to Sublime Text 4?
pinned globally #3


Please stop spamming related topics here in forum and on github with

  1. console logs displaying the already well known symptoms and
  2. all those “I have removed OpenSSL” posts!


  1. there are more than enough of them!
  2. the recommended solution is to install Package Control 4.0 beta, instead of degrating your system’s security level by downgrading OpenSSL!

see also:

Unfortunatelly community can’t sign and upload a final release binary to, which would enable direct installation via Sublime Text main menu.

The current 4.0.0-beta.8 is more of a release candidate as there are no features planned to be added and it seems to work flawlessly for those who are already using it.



Hi deathaxe,

Apologies, as I seemed to have missed the solution with the many overwhelming messages and threads. I assure you I have spent about 2 days looking for solutions before posting what worked for me, maybe there’s a way to pin the solution or make it more promanent so people are more aware?



I seemed to have missed the solution with the many overwhelming messages and threads

the combination of the solutions proposed in the first two issues posted by @deathaxe fixed the package installation for me.



Please correct me if I’m wrong, you worked in SublimeHQ some time ago. Created PackageControl plugin, then left SublimeHQ. Now you’re supporting PC in your free time. But, SublimeHQ won’t lift their finger to make it happen.



Package Control is currently a pure community project which is not related with SublimeHQ beyound them providing an easy to use installer plugin and sponsoring the hosting.

Will Bond is the inventor and original author. He worked at SublimeHQ for several years and is the only one with full access to all PC related repos/resources/servers, AFAIK.

I am just a volunteer - a power user as of 2016 - with push access to Package Control repo (the client part, which is installed on ST) as was contributing some significant changes which helped to start 4.0 branch.

I’ve also prepared a PR to update the webapp to 4.0 with support for python 3.8 at

Will is the only one who would be able to deploy that PR or sign and publish Package Control in a way which makes it accessible for ST’s installer plugin.

I’ve run the webapp in dev mode locally, but not on real production data. I am not familiar with the server infrastructure and - tbh - don’t feel confident enough to overtake its maintanance. I understand the basics of the webapp’s infrastructure, but I never got in touch with CoffeeScript which is used for frontend stuff.