Sublime Forum

Sublime text 4 error

#1

Help, I have tried to use the pawn syntax in sublime text 4 but when selecting it, it tells me this error, what is the reason?

  1. what would be the solution to the problem?

Curiously it happens to me with the latest version, instead with version 3 it works correctly for me

0 Likes

Error Loading Syntax File: C Improved Package
#2

Does it still happen if you install that package in safe mode?

0 Likes

#3

its clearly an invalid regex, maybe ST4 became stricter? to match Oniguruma’s parsing/errors better?
$?

0 Likes

#4

fwiw, the source is $(\n?) but it’s $($?) in ST’s error msg.

0 Likes

#5

Ah I know what the error is. For compatibility \n in tmLanguage are translated to $ which clearly produces an invalid regex in this case.

1 Like

Error loading syntax file ... PostCSS.tmLanguage
#6

So what would be the solution to the problem? what should I do

0 Likes

#7

You may use https://gist.github.com/jfcherng/682bec96a36dc2695b5140726eda5a11 as a temporary solution.

1 Like