Sublime Forum

Sublime Text 4 Does not start


I upgraded to v 4169 from 4166 and now Sublime Text does not start.
I have downloaded the v4169 directly and it also does not start.

  • 4166 worked fine.

I am on MacOS 13.6.1

I have loads to do and debugging my editor is not one of them.

Where can I get v4166


sublime text 4 cannot run

Does it start in safe mode?

We have documentation on downloading previous versions here:



I’m not the OP but I just updated to v4169 on Windows and cannot get sublime to start. I am on Windows.
Also confirmed I cannot start in Safe Mode either.



Do you have an anti-virus or similar software that could be blocking Sublime Text from starting?



My laptop does have anti-virus I cannot control (work laptop). I installed v4169 and reverted to v4152 and am working again.

FWIW I saw the same issue pop up with v4166 and reverted then too after seeing others recommend that as the solution then.

I need to remember to check the forum for a few days after receiving the update prompt I think :slight_smile:

1 Like


Having the same issue, was prompted to update… decided to do that and now it doesn’t even launch. Nothing in the task manager as well.

Cannot disable antivirus but it is not complaining, not being detected as Malware, Spyware or Greyware…

Something just wrong with the build… I even tried reinstalling it.



Downgrading didn’t work also, I uninstalled and went back to 4152_x64 and it’s fine.



4169 is working fine for me (Win 10)



Have to use Windows portable version for a while due to company restricted software installation policy, which was 100% fine until 4166 / 4169 upgrade. Both 4166 (both auto upgrade and portable redownload) / 4169 (portable redownload) cannot be started, has to revert back to 4152.

1 Like


Windows 10 64bit Installed version - Corporate machine

Broken builds: 4166 and 4169 - cannot start the program. No error message or pop-up or stalled process.

All prior builds are okay and can start, for example build 4152 is okay - just like prior commenter.

1 Like


I also have this issue on Win10. Updated a few days ago and now Sublime Text does not launch. No error message and no process showing in Task Manager.

ETA: Uninstalled and re-installed build 3211. It launched with no issues. 4126 launch with no issues also. 4152 did; 4169 did not. So, went back to 4152.



I have a similar issue on Win 10 tried to update to 4169 and sublime would not start. Reverted back to 3211 which then upgraded to 4126 and sublime started again. Then tried to upgrade again to 4169 same behavior it will not start.

Has anyone found a solution.


Windows 10 Enterprise - Version 22H2 OS Build 19045.3758


1 Like


Safemode of v4169 did not work either.
– I also saw ST v3 instances in the filesystem
– When I say did not start in the fore-ground, I mean the ST process started but the GUI would not appear. I could view the process and I could kill the process and get back my command prompt.

I had to remove that version and the install the v4166, which was my previous version.

  • I tried to start v4166 and that would not start either.

I rebooted the Mac and then v4166 would start correctly.

I am very surprised that a fix has not been published already because so many users have been reporting this issue. I am very surprised that a major version was published and it would not start, which will be the first test – Can the app even start ??



Thanks for the tips. I can use Sublime Text (4126) again!

And, you are right, unfortunately, upgrading to 4169 broke it again.



It’s working for thousands of people and the only cases I’ve seen where it hasn’t is when anti-virus or similar software is getting in the way. If it’s not working in safe mode it’s most likely an issue with your specific setup. Note that 4169 and 4166 are essentially identical apart from some minor crash fixes.



Sublime Text has been working perfectly for decades, and I have been using it for more than ten years. This is the first time I have this issue. And apparently, I am not alone.

One thing I noticed is that when Sublime Test 4169 tries to start, “werfault.exe” started (in the background) and then both process were killed. Hopefully this information is helpful.



You could try using procdump to get a crash dump for me to investigate. werfault.exe being triggered would mean that it’s crashing before starting our own crash handler.

After download procdump you can run .\procdump.exe -t -e -w sublime_text.exe in a terminal. This will wait for Sublime Text to start and then monitor for a crash.



For some reason, ProcDump does not work on my computer. It stick at this step for a long time, and I have to stop it. It is not just for Sublime, it could not start any program.

λ Procdump\procdump64.exe -t -e -w sublime_text_build_4169_x64\sublime_text.exe

ProcDump v11.0 - Sysinternals process dump utility
Copyright (C) 2009-2022 Mark Russinovich and Andrew Richards
Sysinternals -

Waiting for process named sublime_text_build_4169_x64\sublime_text.exe...


You need to pass just sublime_text.exe. You’re not providing the path to an executable, but the name of the process. You then need to run Sublime Text separately.



If you’re ok with sharing it privately you can send it to Note that the dump created is a minidump, it doesn’t contain a copy of the memory. Without a way of looking at the crash there’s nothing more I can do.

1 Like