Sublime Forum

Sublime Merge - Unable to use bundled license w/ `snap`?


I just purchased a bundled license (see Sublime Merge license discount for Sublime Text Registered Users?). I successfully entered in license for Sublime Text, but not Sublime Merge.

Email leads me to believe that it should’ve worked:

Entering the license details:

  1. Open Sublime Text & Merge, and expand the Help menu.
  2. If you see Remove License in the menu, select it.
  3. Re-open the Help menu and select Enter License.
  4. Copy the license above (including the BEGIN LICENSE and END LICENSE lines) and paste them into the license box.
  5. Press the Use License button and Sublime Text & Merge will enter into licensed mode.

I am on Ubuntu 20.04, and installed using snap:

# Installation
$ sudo snap install --classic sublime-text
$ sudo snap install --classic sublime-merge

# Versions
$ sublime-text.subl --version
Sublime Text Build 4121
$ sublime-merge --version
Sublime Merge Build 2020

My guess is, the snap distribution is trailing behind?



K, uninstalled snap versions and installed via their apt repo:

Now it works!

$ subl --version
Sublime Text Build 4121
$ smerge --version
Sublime Merge Build 2063


Hi @eacousineau,

Thank you for your support, and glad to hear it’s working for you now!

Support for bundle license keys was added to Sublime Merge in build 2056.
As you’ve noted, the version available on the snap repository is outdated.

You can always find the latest versions available through our official distribution channels shown at

- Dylan from Sublime HQ