Sublime Forum

ST3 Screen flicker in linux


I’m experiencing screen flicker in linux using ST3.

I recorded a short video:

It does not happen on screen recording using software.

I have deleted ~/.config/sublime-text-3 to test this so it’s in a clean state.

My environment:

Archlinux 64 bit

CPU: i7-6700HQ
Using integrated intel GPU

DPI scale: 1.473
startup, version: 3126 linux x64 channel: stable

I do not see similar problems in other applications (chrome, firefox, terminal ,etc.)

Anyone experiencing the same issue?




I do have the same problem. It’s really annoying because it can take up to 3-5 seconds to show the text clearly after scrolling. It affect also the other UI elements, such as the tabs or sidebar.

Using Archlinux 64 bit

CPU: i3-4005U
Using integrated intel gpu

I don’t have trouble with any other app and OpenGL rendering seems fine (tested using glxgears).



This makes me think it is somehow connected to your video card driver.

Sublime Text does not use OpenGL on Linux. OpenGL is only utilized on OS X.




When my laptop is connected to an external monitor (via HDMI, but still using integrated intel GPU), the flickering disappears on BOTH external monitor and builtin monitor. Then if I move sublime window back to the builtin monitor and disconnect the external monitor, the flickering comes back.

It seems like it’s related to video card driver indeed.

I am using the kernel builtin intel graphic driver according to
My kernel version is 4.11.3

I can switch back to an older kernel or try the xf86-video-intel driver to see if it makes any difference. I would keep you updated.



Update 2:

I just switched to xf86-video-intel driver and it seems great. I haven’t noticed any flickering yet. I would give it some time to see if there’s any other issues.



Okay, that’s interesting. I have to test it too.

Update: yes, the problem is gone after installing the Intel driver.



Grrr. So I just noticed this after not using sublime for a while. It’s great to find that others have it, but not great to find out that a possible solution might be xf86-video-intel. I had a problem with sublime and a bunch of other applications about a year ago that was fixed by removing xf86-video-intel. There was a much bigger thread that also suggested removing this driver in favor of the modesetting driver.

I’d prefer not to go back to the intel driver if I can avoid it! Any other thoughts on settings or root cause?

I’m also on arch linux, though I use bumblebee (nvidia discrete, intel integrated). Oddly, I get the artifacts when I do optirun subl3, which should be using the nvidia card, not intel).


Mods: please assist with hidden posts

I tried optirun subl3 also, but it seems that it would not use the nvidia card (check os.environ['DISPLAY'] in sublime console), I haven’t found the reason yet



I get :0 with that command (had to import os first). My cards:

$ lspci
00:02.0 VGA compatible controller: Intel
01:00.0 VGA compatible controller: NVIDIA

Not sure if :0 means intel or Nvidia…



Run ps aux | grep Xorg in terminal, e.g. this is my output

root       568  0.5  0.8 710612 136068 tty7    Ssl+ Jun05  34:18 /usr/lib/xorg-server/Xorg :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
root     23417 28.0  0.2 262776 48408 ?        Ssl  09:59   0:00 /usr/lib/xorg-server/Xorg :8 -config /etc/bumblebee/xorg.conf.nvidia -configdir /etc/bumblebee/xorg.conf.d -sharevts -nolisten tcp -noreset -verbose 3 -isolateDevice PCI:01:00:0 -modulepath /usr/lib/nvidia/xorg,/usr/lib/xorg/modules

which shows that the Xorg using Intel card is on DISPLAY :0, and the Xorg using Nvidia card is on DISPLAY :8

1 Like


Thanks, I get the same (so it’s just using intel).

I’m having all sorts of issues now… what started as a simple attempt to try this with nvidia revealed that optirun glxgears -info is super glitchy/jittery. Then I tried with primus instead, it worked once, then refused the second time. dmesg said to run which froze my whole system. I get issues about my GPU “having fallen off the bus” and other ick in dmesg too. Really odd.



This thread brings back memories of the pain and suffering that was dealing with nvidia optimus graphics. I can’t even remember how many days I spent over the few years of having a Lenovo that I spent trying to get graphics to work properly and efficiently. Hot plugging was a no-go for a while, and when using the nvidia card, where was no throttling, so the battery lasted about 1-1.5 hours.