Sublime Forum

ST2&ST3 crashes while opening file browser dialog

#1

Problem: Sublime crashes when it tries to open the file browser dialog on my system.

Steps to reproduce: one of the following ->

  • File>Open
  • File>Save
  • Project>‘Add folder to project’

I use Debian. I have to ‘Force quit’ the application, unfortunately.

My configuration:

  • Fresh installed Sublime Text 3 Stable, build 3065.
  • Linux CrunchBang Linux 11 “Waldorf” 64bit (= Debian based)

What I tried:

  • I searched for logs. Can’t find those.
  • I tried to use an ‘Open file’ dialog in other applications. This works.
  • I deleted my configuration files and reinstalled S2 as well as S3. The problem still exists.

I now use Geany as text editor, but dang, want to go back to Sublime as soon as possible :smile: Any suggestions? What could this be?

0 Likes

#2

Sublime still does crash on my computer, on “File Open”, “File Save” and other operations where the file dialog should open.

Does anyone know what file dialog software Sublime 2/3 utilizes (Debian)? If I know the name, maybe I can find logs for it.

Thank you in advance!

0 Likes

#3

I have the same problem. I’m using RHEL6 though.

0 Likes

#4

i’m aware this is a very old thread but i’d still like to reply in case i can help people googling this problem :slight_smile:
i had the same problem and in my case it was wrong permissions on /usr/share/glib-2.0/schemas/gschemas.compiled. apparently this file was installed with 0600 root:root permissions, so no user could read it (it might be connected to the fact that i am using a 0077 umask on my system).

TL;DR: sudo chmod 644 /usr/share/glib-2.0/schemas/gschemas.compiled

fixed my problem.

1 Like