Sublime Forum

[solved ] ctrl-space doesn't complete

#1

Hello community

I’m trying sublime so my installation is very basic ; however I cannot find out how to have autocomplete working. I think I understand it’s “ctrl-space” but for me it does something like “select all” instead.

What am I doing wrong?

TIA

greg

1 Like

#2

If you are on Linux, ctrl+space is not bound to autocomplete. Drove me nuts :frowning: I think it’s because it conflicts with a system keybinding (something having to do with Kanji characters, if I recall correctly). You can add the binding yourself, I guess.

2 Likes

#3

Thanks for your answer.

How can I bind it myself? I figured out how to bind a command to a key, but what command is autocomplete?

TIA

0 Likes

#4

Hej :smile:

If you paste this code into you user keybindings, and change “alt+/” to “ctrl+space” then it will do what you want to do :smile:

{ “keys”: “alt+/”], “command”: “auto_complete” },
{ “keys”: “alt+/”], “command”: “replace_completion_with_auto_complete”, “context”:

		{ "key": "last_command", "operator": "equal", "operand": "insert_best_completion" },
		{ "key": "auto_complete_visible", "operator": "equal", "operand": false },
		{ "key": "setting.tab_completion", "operator": "equal", "operand": true }
	]
}

Ps: I don’t have any problems with the change under Ubuntu 12.04 :smile:

1 Like

[Solved] Using ftp through Nautilus the writting is delayed
#5

It’s working great! thanks a lot!

0 Likes

#6

oh my this was driving me mad.

0 Likes

#7

Below is my “sublime-keymap – User” file. I thought Glorforidor’s answer was weirdly formatted.

[
	{ "keys": ["ctrl+space"], "command": "auto_complete" },
	{ "keys": ["ctrl+space"], "command": "replace_completion_with_auto_complete", "context":
		[
			{ "key": "last_command", "operator": "equal", "operand": "insert_best_completion" },
			{ "key": "auto_complete_visible", "operator": "equal", "operand": false },
			{ "key": "setting.tab_completion", "operator": "equal", "operand": true }
		]
	},
]

Hope this helps someone!

0 Likes

#8


Thank you very much this helped me.

0 Likes

#9

GRACIAS!! Esto me volvía loco

0 Likes