Sublime Forum

Snippets are not listed in auto complete popup anymore (ST4)



I’ve just updated to ST4 and when I start typing my snippet trigger, the trigger is not listed in the auto-complete popup anymore.

I found that the only way to see it listed in the auto-complete popup is to use ctrl+space, that is an extra step.

With ST3 I could just type the first letters and my snippet trigger was right there.

I tried to change some of the auto-complete settings but no luck…

Am I missing something?



ST4 - Snippets won't get inserted at first

Are you using the PHP or HTML syntax by any chance?



I’m in a .vue file but because it’s not natively supported, I think it’s based on the HTML template.

I’ve just tried with a .js file and the snippet shows up.

I guess it’s a known issue that will be fixed in a future release?



I use PHP syntax, but I can’t trigger my snippet trigger fragment like ST3



It’s not related to PHP or any certain syntax. I saw several snippet related reports about this issue.

It just seems to be a side effect of how snippet function has been merged to auto completions and the fact number of completion items to be limited. This way snippets get burried if too many other completions are present, which ST thinks are more relevant.

With some luck hitting ctrl+space after typing the tabTrigger to refresh completion popup adds desired snippet or sometimes not.

see also:

Also asked at User Snippets not working properly