Sublime Forum

Preferences greyed out in OS X


What version of macOS are you running? Have you removed all third-party packages to see if it works in a clean state?

I believe that the issue is happening, but it is one of those bugs where no one can figure out what is happening, and if we can’t reproduce it, we have no idea what to do to fix it.



This just happened to me. Then I’ve uninstalled the latest two packages that I had installed and the Preferences menu became available again. The two packages were “Advanced CSV” and “CSV”. Sublime Text 3 version 3176, OS X High Sierra 10.13.4 (17E202).

And then I installed these packages again, but the menu still works. At some point, some submenus were greyed out (while I was editing user settings for the package), but then they also became available again.



Nothing worked until I deleted everything from the cache directory in ~/Library/Application Support/Sublime\ Text\ 3/Cache.

ST3 complained about a missing package or something and needed a restart. After that preferences worked again. In the Cache dir I saw caches from old packages that had long been removed.

Hope this helps. Worked for me but YMMV.



Same thing is happening to me. ST3 3176, macOS 10.13.6.

Random. Every 3 or 4 launches, Prefs menu will work normally. Otherwise greyed out. Cmd-, works to access but there are a lot of other submenus that are usually there that can’t be accessed. No errors in my console on startup. Why is this happening?



I have the same annoying Bug and it’s going on for quite some time (maybe 2 years or so)…
Can we finally find out why it happens and resolve it?
It happens on my 10.13.6 machine all the time. @wbond I am willing to do some remote debugging together with you. You could connect to my machine and we inspect together what is going on. I know that many others have the same issue, they are just not verbose about it.



Same here. build 3175, macOS 10.13.4.

It’s been a month more or less since I last saw a non-greyed preference menu…
Tried uninstalling Emmet, deleting cache among others recipes.
Nothing worked.



Having this issue right now… build 3176, macOS 10.13.6 … Haven’t added a new Sublime Package in forever, but it’s possible one updated itself. Restarting Sublime does not change anything. Any suggestions on how to incrementally change things that would be helpful? I feel like a whacking the cache is too heavy handed to help solve the problem for good.

EDIT: Restarting Sublime does change things…it’s seemingly random but sometimes it comes up and it’s good, and other times not, much the way that it was described in Preferences greyed out in OS X



fixed in build 3180