Sublime Forum

Preferences greyed out in OS X


Interesting. I haven’t heard or or seen mention of this before. Is it only in specific situations (like in plugin_loaded())?



I think it only has a chance of occurring at startup, but I’m not 100% sure. I believe it only applies to accessing a value not currently in view.settings. It seems like there is a weird case where any setting you attempt to access that does not exist will return None despite what you give as a default. But it is very sporadic as other times we don’t get None.

Some of my plugins will write info to the view.settings to access view specific info later, so I’d expect if they haven’t been set yet, that you’d get the manually provided default instead of None.

I’m not usually accessing view specific settings directly in plugin_loaded. I’m either accessing them in normal sublime commands, Sublime events, things like that. I may access them from a function that is called from a thread, but the thread kicks off this action by calling sublime.set_timeout or sublime.set_timeout_async and usually only once a normal sublime event has communicated that it has processed an event that we need to take action on.



I had this problem today. Restarting Sublime Text did not help, but the mentions of SecondBar above led me to try quitting and restarting Bartender, which did the trick!



A great answer to this question would be, How does a plugin cause the Preferences menu to be disabled? Does a plugin have the ability to override the menubar in that manner?

I don’t want to disable all my plugins one at a time looking for the answer to this question. Currently the only answer is a reboot. A REBOOT!? And that’s only good until the next time.



There isn’t any evidence so far that a plugin is going that. There have been some suggestions that third-party Mac apps may be causing issues.

If anyone can reproduce the issue and fix it by removing third-party packages, I’d be grateful if you can identify which plugin is causing the issue, so we can look into how that could be happening.



Here are some findings from my side. I have to remove

~/Library/Application Support/Sublime Text 3/Lib/python3.3


~/Library/Application Support/Sublime Text 3/Installed Packages/PyV8

both get re-created when I restart Sublime Text. When these are there, then the Preferences menu is greyed out. If I remove then and then start Sublime Text, I can access the Preferences menu, until, I quit Sublime Text and forget removing them.

So it has something to do with python, but I’ve no idea how.

Also, I’ve some packages installed, but besides the PyV8, which gets re-created, none of the others seem to hurt by themselves.



This is automatically created by Sublime Text itself, and is part of sys.path. Unless you placed files there, it will be empty, and should not affect anything.

This is installed by a package you’ve installed - most likely Emmet. Try removing Emmet and then delete PyV8 to see if your preferences menu works.



This happens when plugin_host fails to run, I had to chmod +x plugin_host and everything went fine.



Moral of the story: if something’s broken, try disabling Emmet. Even if there is no conceivable way that Emmet could be responsible.



So annoying still happening with build 3170. is there any fix for that ? as nothing works even rebooting … will have to have a look at vs code now.



It seems to be related to users running third-party software on their machine, as best we can tell. No one has yet been able to provide a way to reproduce it, so it isn’t clear what we could do to fix it.



Nothing is running on the mac only sublime. still the same issue …



What version of macOS are you running? Have you removed all third-party packages to see if it works in a clean state?

I believe that the issue is happening, but it is one of those bugs where no one can figure out what is happening, and if we can’t reproduce it, we have no idea what to do to fix it.



This just happened to me. Then I’ve uninstalled the latest two packages that I had installed and the Preferences menu became available again. The two packages were “Advanced CSV” and “CSV”. Sublime Text 3 version 3176, OS X High Sierra 10.13.4 (17E202).

And then I installed these packages again, but the menu still works. At some point, some submenus were greyed out (while I was editing user settings for the package), but then they also became available again.



Nothing worked until I deleted everything from the cache directory in ~/Library/Application Support/Sublime\ Text\ 3/Cache.

ST3 complained about a missing package or something and needed a restart. After that preferences worked again. In the Cache dir I saw caches from old packages that had long been removed.

Hope this helps. Worked for me but YMMV.



Same thing is happening to me. ST3 3176, macOS 10.13.6.

Random. Every 3 or 4 launches, Prefs menu will work normally. Otherwise greyed out. Cmd-, works to access but there are a lot of other submenus that are usually there that can’t be accessed. No errors in my console on startup. Why is this happening?



I have the same annoying Bug and it’s going on for quite some time (maybe 2 years or so)…
Can we finally find out why it happens and resolve it?
It happens on my 10.13.6 machine all the time. @wbond I am willing to do some remote debugging together with you. You could connect to my machine and we inspect together what is going on. I know that many others have the same issue, they are just not verbose about it.



Same here. build 3175, macOS 10.13.4.

It’s been a month more or less since I last saw a non-greyed preference menu…
Tried uninstalling Emmet, deleting cache among others recipes.
Nothing worked.



Having this issue right now… build 3176, macOS 10.13.6 … Haven’t added a new Sublime Package in forever, but it’s possible one updated itself. Restarting Sublime does not change anything. Any suggestions on how to incrementally change things that would be helpful? I feel like a whacking the cache is too heavy handed to help solve the problem for good.

EDIT: Restarting Sublime does change things…it’s seemingly random but sometimes it comes up and it’s good, and other times not, much the way that it was described in Preferences greyed out in OS X



fixed in build 3180