Sublime Forum

Passphrase is asked each time


Hello. I used the Sublime Merge on macOS.
And I impressive on its fast performance and comfortable.

But when I use pull, fetch or something like remote works, then Sublime Merge asked passphrase every time. I find how can I using keychain feature, but it looks not yet supported.

Sublime Merge dose not have keychain feature?



You can use Tools -> Password Caching or possibly the solution(s) found in Build 1075 keeps prompting for credentials.



Where is this “Tools > Password Caching” you speak of?



It was added in dev-build 1066 and released in build 1070. Based on the release note (pasted below), it may only be supported on Linux & macOS.

Added a Tools/Password Caching menu to easily setup credential caching on Linux



Ah. I’m running build 1084 on Windows and still have that nagging prompt. I haven’t tried switching to the system version of Git yet (was kind of hoping it would get fixed in SM).



Is there an option for password caching to be unlimited? On linux build 1084.



It looks like that password caching not working in dev-build 1111. Does anyone have the same problem with this build?



SM 2011 on Win10, the problem still persists. See the bug report on GitHub:

If anyone has a solution to this, please help us out. All the credential files are present in the system and picked up correctly by all Git installations and front-ends, except SM which keeps asking me to type the password when connecting to a GitBlit local server over Intranet (ssh connection).

Any actions I could take locally to make the credentials visible to SM?

1 Like


That is a long unsolved issue with git command.

Make sure your password works or create a PAT:

You can also try saving the user-password to a plain-text file, effective when OS credential system fail:

git config --global credential.helper store

Then entering user-password again