Sublime Forum

Build 1075 keeps prompting for credentials


Every time I push to origin now, I am prompted for my password. This wasn’t happening in previous builds. Anyone know how to prevent this? Thanks.

1 Like


Hi @Fotiman,

This may be due to Git’s credential cache time-out being set to zero or unset.
Try running git config credential.helper from the repository directory, and confirm the output is not empty or set to zero.

Kind regards,

  • Dylan Johnston
1 Like


I have the same issue, and it also started with Build 1075. My credential.helper setting is set to “manager” (Git Credential Manager for Windows)

1 Like


It’s set to manager.



Hi Fotiman,

Can you confirm whether you are using SSH or HTTP to access your remote repository?


  • Dylan


In my particular case, I’m using HTTP to access the remote repository.



Having similar trouble using windows git credential manager, using http and AWS codecommit



Sorry for my late reply (my account was locked after my previous reply for some reason). In my case, I’m using HTTPS to access my remote repository.



I think it happens because SM uses not the latest version of git. When I switched from bundled to system version (Preference-Git binary-“System”) error was fixed. With the bundled version I also get the other errors in pull process. The same errors I got before update the system git.

1 Like


Thanks! That workaround works for me.


Passphrase is asked each time

Given that this seems to be related to the bundled version of Git, can anyone confirm whether this is being worked on? Does the bundled version need to be updated to a newer version or something?



I’m not certain the git version is itself the issue. It appears that SM has the latest maintained build (2.19.1) included. It’s probably a configurational change that happened in recent builds. If it works, use system preference workaround as indicated above for now. I’d suggest filing a bug report about this.

Related, I’m wondering whether it’s possible to tell SM explicitly which git on your system to use? My git is installed in a nonstandard path and I’d like to tell SM to use it…




You should be able to use the git_binary setting for this by setting it to the fully qualified path to the git binary to use.

1 Like


Ah, sweet. Didn’t realise you could just plumb in a path there. Thanks! :slight_smile:



Bug report opened: