Sublime Forum

Mouse click does not work on the text


Hello, I downloaded the SublimeText2 (Linux 64 bit) and it runs normally, but I can not move the cursor by clicking with the mouse. I can only move using the arrows =/
I use openSUSE 12.2 (x64).



I found the solution here: Problem: drag_select
but I have to export LC_NUMERIC = C every time I run the Sublime, does anyone know a definitive solution?



This is a bug in Sublime. Sublime sets LC_NUMERIC to “C” after startup (see Problem: drag_select), probably after initializing GTK, which, according to the GTK docs, “may produce inconsistent results and is not really supported” ( … set-locale). This can’t work reliably because modules loaded by GTK at a later time may set the locale again. In the case of openSUSE 12.2, GStreamer is calling setlocale(LC_ALL, “”) which sets the locale to the one specified in the environment.

A note to the developer of Sublime: It is wrong to set the locale to “C” in programs that interact with users. Functions processing formal language text, such as configuration files or program code, should always be locale-independent. (Emacs has the same problem; see also my comments at



This is 2018, and since last week my Sublime Text 3, Build 3156, has got this bug again under Void Linux.

Now in order to have a usable mouse on Sublime, I need to start ST each time prefixing EXPORT LC_NUMERIC=C

Can this pleeeeeeeeeaaaaaaaaase be solved at the source code level…?



bruh moment year is almost 2022 same shit still happens for me too and no one cares . i cant even make selection with mouse and only in sublime !



We’ve got a fix for this that should be shipping with the next build.