Sublime Forum

Hide/remove list of recent files on right click on dock icon MAC



after update to v. 4142 there is some weird list of recent files on click on icon in dock on the Mac OS.

As I’m not using Sublime only for view text files but mostly for upload to FTP via Transmit, it’s incomprehensible for me to know which files are already open and which have been closed.

I’d like to see in the list, after right click on icon, only active (open) files as it was before.

I’ve searched a lot on Google, in this forum and in Sublime settings as well. With no success.

Thank you for any help.



See the "update_system_recent_files" setting.



Thank you but it didn’t help.

Have a look closely. The files with a Sublime logo are closed. Active/open are only both on the bottom.



Maybe disabling the setting doesn’t clear already existing entries?



Yeah, it’s possible but how to remove already existing entries? :slight_smile:




Anyone found a solution for this? I have tried to remove the items from the “file_history” list in Local/Session.sublime_session without any luck. Wondering if this is more related to OSX cache now…



Try to remove this file and then restart Sublime Text:

( thanks to: )

$ rm ~/"Library/Application Support/"

I think Sublime Text 4 should empty this file automatically when user clicks “Sublime Text” -> “File” -> “Open Recent” -> “Clear Items” from the menubar.

I set "update_system_recent_files" setting to false so as not to create any recent file list on Dock icon later.

1 Like


I was going crazy and I’d been looking for a solution for this for over a month now. I’d gotten as far as knowing com.sublimetext.4.sfl2 was the culprit, but no matter what I did, the file would get recreated by macOS upon reopening and then closing Sublime Text. I finally got rid of that list thanks to this thread, so here’s what I did:

  1. click File > Open Recent > Clear Items
  2. add "update_system_recent_files": false to Preferences.sublime-settings
  3. quit Sublime Text
  4. delete ~/Library/Application Support/
  5. open Terminal and run killall sharedfilelistd (THANK YOU @silverzhaojr for the link)
  6. reopen Sublime Text, list is gone

If you don’t run killall sharedfilelistd the file just keeps getting recreated over and over, that’s what I was missing.