Sublime Forum

Folders show a strange icon and can't be opened

#1

This is happening in folders inside the /node_modules/ folder.

Has been happening for a while. No idea where those folder icons come from (the ones with an arrow inside). I only see them when this occurs.

Using Sublime 3 build 3126
Theme “Soda Dark 3”
Mac Pro, Sierra 10.12.5

2 Likes

#2

The icon means those folders have been seen before by the folder index, and due to the nature of symlinks, allowing duplicate folders to be enumerated could result in an infinite list of files. Thus, when a folder has been seen before, subsequent copies are marked as duplicate and skipped over.

0 Likes

#3

And so how do I open the folder, to see the files?

As it is, that folder is a useless place to click on the sidebar.

I have to “Reveal” the folder in Finder and drag the file into Sublime.

Sublime should be able to determine what to show in there without creating troubles I would suppose.

0 Likes

#4

You’ll have to click on the folder in the first location it exists in your folder tree.

Currently it let’s you know you have symlinks in your system, and it knows they exists. The current limitation is that it can’t expand them because it would require we allow the possibility of an infinite folder index. The folder index is what powers Goto Anything. If you have a recursive symlink where a child refers to a parent, it would result in the folder index never reaching the “end” of the recursion, so it could never finish indexing your folder list. Thus instead, if we’ve already seen a folder, we skip scanning it a second time. The downside about the current implementation is that the folder list in the sidebar has a 1:1 mapping to the folder index.

As I explained above, recursive symlinks are the reason the current implementation doesn’t. In order to get around this we’d have to change the sidebar implementation to not map directly to the folder index. It is certainly a possibility we’ll do this in the future, as the current implementation isn’t the ideal interface when symlinks are present. The sidebar rewrite that is part of the current dev cycle is a step in that direction.

0 Likes

#5

This is a horrible bug that did not exist in previous versions of Sublime and is unacceptable. A user must be able to open a folder if the folder is there, period. As users we are not concerned about the internals and why this is happening.
This is slowing down my work immensely and unless this is fixed in the coming weeks I will be switching to Atom I’m afraid and it’s a shame because everything else about Sublime works really well.

1 Like

#6

This seems to be interacting badly with WinSSHFs for me. In my console output, I’m seeing:

scan: /D/project/lib/flash has been seen before, skipping (using inode) previous path: /D/project/test/flash inode: 351315677
scan: /D/project/lib/i2c has been seen before, skipping (using inode) previous path: /D/project/test/i2c inode: 533846050

/D/ maps to my home directory on a remote ubuntu machine, and I’m running this on windows.

These two folders are not symlinks to one another, and contain different contents. Sublime refuses to show the contents of the folders under lib, which requires me to open them manually.

What can I do to clear the cache of the indexer and try again?

0 Likes

#7

Also having this problem with WinSSHFS. Folders that are clearly not symlinks and have different contents are being skipped due to similar names.

0 Likes

#8

I’m also using WinSSHFS to map from Ubuntu to a Network Drive on Windows. I have the same problem. I have a lot of “src” folders in the second level of the folder tree, all those folders get ignored. The main problem seems that the identification algorithm is to simple. It seems to only look at the basename of the path, the last component. The only solution for me so far is to downgrade to previous versions and ignore the update button that comes up at every start. update: Found the config for disabling updates, great piece of software :slight_smile:

Also: so far i had problems with some of those directories too, but i could always right-click+refresh and tree below got loaded, that was not possible anymore with the current version 3176

0 Likes

#9

Same here, using WinSshFS… I’ve been having to manually open the files rather than from the sidebar. I’d really like a fix because this is the first time I’m encountering this issue and I’ve been trying to figure out what the issue is. I’m going to have a look for alternatives to mount on Windows with ssh but as far as I know, WinSshFS works best…

Edit:
I’ve found https://github.com/billziss-gh/sshfs-win which works too but I feel like the other program works better… As far as I can see, files and folders don’t become hidden in Windows which can be a little weird.

On the GitHub page, go down to “How to install” and install WinFsp and SSHFS-Win. Don’t install SiriKali which is recommended near the bottom. It’s a GUI. It’s buggy and it doesn’t seem to work for me. Then I recommend you do this and enter your \\sshfs\ directory, as on the page at "How to use"

0 Likes

#10

Hello,
Same issue for me with WinSshFS
My fix : downgrade to the build 203143 by using this link for the win64 version.

I hope the excellent sublime text developpers will fix this issue soon. :slight_smile:

Edit: perhaps the problem could be fix in WinSshFs : Some folders cannot expand in "Folders" tab when connected via SSH

0 Likes

#11

There is an ugly workaround that sheds a little light into where the problem lays. I recently switched back to a current build and tinkered around with the project settings to make it somewhat workable.

You have to seperate all folders where duplicate folder names (which dont get loaded) reside into seperate folder configurations.
{
“name”: “PROJECT-NAME”,
“folders”:
[
{
“name”: “Cgi”,
“path”: “{{PATH}}\Cgi\src”,
“folder_exclude_patterns”: [],
“file_exclude_patterns”: [],
“follow_symlinks”: true,
}, {
“name”: “Cli”,
“path”: “{{PATH}}\Cli\src”,
“folder_exclude_patterns”: [],
“file_exclude_patterns”: [],
“follow_symlinks”: true,
}
]
}

Thought I didn’t figure out how to make nested folder structures this way. Maybe you guys have an idea.

0 Likes

#12

Hi @_jordan, the downgrade fixed it for me too, thanks for posting the link.

0 Likes

#13

I had the lastest Sublime release loaded. Could not get the stupid folders to work. They are not even “links”. I’m using “SFTP Drive” to connect from my Windows 10 PC to a remote Linux host. And for whatever reason (I’ve spent the last hour reading dozesn of “wbond” replies to so many people on so many forums about this. No, follow_symlinks did not work. No downgrading to the version listed above did not work. Yes, I recreated new projects clean to retest. Still the same bullcrap: random folder icons with little “link” symbols in them, where when I go onto the Linux host and check them, they are actual directories. Whatever “folder index” Koolaid the Sublime developers have been drinking is clouding their judgement. The approach is wrong. No “other” folder link reference appearing “somewhere” in a project containing thousands of files and hundreds of directories should mess up my ability to drill into a non-symlinked folder under the current directory in the sidebar tree… ever.

I just tapped out. I’ve used Sublime Text for years, customizations and all that. But it’s usable to me now. Something as basic as navigating a source tree should not be fraught with landmines of problems and hours of research to fix using arcane text config file entries, etc. I’m done. I just downloaded the free Visual Studio Code app and no more issues. I’m over it. MS has caught up and blown right past Sublime Text, and this is the kind of issue that doesn’t help your loyalists.

PS - I just subscribed to this forum just to post this message. Bye now.

0 Likes

#14

can you please fix this, 2020 is almost over. I dont want to switch VScode because of not able to open folders and files in sublime. (Same issue, I have multiple same name folders under different paths, they are for sure different folders, and sublime thinks that they are same and unclickable, just display symbolic link icon) I am also living this problem on shared folders from a vm. File explorer, VS Code, any other editor just show them fine.

0 Likes

#15

Problem is still there and can’t work around it because it occurs at random and I’m talking about hundreds of folders and subfolders flagged as symlinks when I don’t have a single symlink in my project. Do we know when a fix will be pushed? I can find a file in one of those folders with Find Anything but when I do Reveal in Sidebar, it just scrolls all the way to the top of the sidebar.

0 Likes