Sublime Forum

Ctrl+Alt+Up/Down not working

#1

The select_lines command, bound by default to ctrl+alt+up and ctrl+alt+down has stopped working recently, and I’m not sure why. In the default key bindings, I have the following lines:

{ “keys”: “ctrl+alt+up”], “command”: “select_lines”, “args”: {“forward”: false} },
{ “keys”: “ctrl+alt+down”], “command”: “select_lines”, “args”: {“forward”: true} },

And there’s nothing that overrides these in user key bindings. If I change the binding to shift+alt+up/down, it works with the new binding, but when I change back it stops working again. Alt and Ctrl both work properly with other commands. Any ideas what’s going on? Thanks for any help.

0 Likes

Multiple cursors
#2

You have to CHANGE the configuration of your intel quick access option to rotate the screen.
This is it, If you only desactivate, won’t work.
You should return the configurations files to default if you have modify it.
http://thumbs.subefotos.com/dc5c768792687b8e2b6690e838df2772o.jpg

1 Like

#3

That worked fine for me.

Just to clarify:
I at first tried to deactivate the keys in the Intel HD graphics control panel. As the previous post indicated this is not good enough.
I the modified the keys by assigning some function keys to it like: CRTL+ALT+F6
Then I also deactivated those keys because I don’t need them.

Everything is fine now.

0 Likes

#4

Can confirm, I also had to remap the bindings (not just disable) in order to make the bindings work in ST. I only had to do it on my 8.1 laptop though, the 7 desktop worked with just disabling the Intel bindings.

0 Likes

#5

this just helped me; for some reason i had to add this to my keybindings.
just note a small mistake with missing brackets
below is fixed

{ “keys”: [“ctrl+alt+up”], “command”: “select_lines”, “args”: {“forward”: false} },
{ “keys”: [“ctrl+alt+down”], “command”: “select_lines”, “args”: {“forward”: true} },

1 Like

#6

Ubuntu 16.04, same issue. ctrl+alt+up/down not working. Checked the key bindings and it’s nowhere to be found. I thought it was a default?

Adding @trevorsg’s solution did not change behavior.

[
{ "keys": ["ctrl+alt+up"], "command": "select_lines", "args": {"forward": false} },
{ "keys": ["ctrl+alt+down"], "command": "select_lines", "args": {"forward": true} }
]

How do I insert the cursor into multiple lines, without pointing and clicking?

0 Likes

#7

The default binding for this functionality on Linux is:

	{ "keys": ["alt+shift+up"], "command": "select_lines", "args": {"forward": false} },
	{ "keys": ["alt+shift+down"], "command": "select_lines", "args": {"forward": true} },

The ones posted above (Ctrl+Alt+Up/Down) are the Windows default bindings (now at least; they may not have been in 2011). I would try using the Linux defaults (you shouldn’t need to change any key mappings) and see if that works better for you.

Having key bindings like the above that don’t work is generally a symptom of something external to Sublime eating the key before Sublime gets to see it. In the above posts that’s what’s happening; the Intel graphics software on windows uses those keys by default so Sublime can’t see them.

The same can happen on Linux as well, though it’s generally your Window Manager that sees the keys and acts on them instead of passing them to the application. That might be why the bindings are different on Windows than they are on Linux.

0 Likes