Sublime Forum

Build 3200 in RHEL 6 missing GLIBC_2.15


3176 works perfect but 3200 is broken in RHEL 6.

/lib64/ version `GLIBC_2.15’ not found (required by /home/XXX/sublime_text_3/sublime_text)

It is a company’s server. I can only put file in my home folder.

1 Like


+1, same problem. According to this other post it seems like the GLIBC dependency changed with build 3180.

It would be really nice to get this fixed, as RHEL 6.x is still very popular.



The same is true on CentOS 6 x32 where I’ve just run into the same problem. 3176 was fine, but 3200 seems to want glibc 2.15, which isn’t available on C6.



+1, same issue here. RHEL 6.8 from company server. 3176 worked but 3200 is broken with the same error above:

/lib64/ version `GLIBC_2.14' not found (required by /home/<user>/sublime/sublime_text)
/lib64/ version `GLIBC_2.15' not found (required by /home/<user>/sublime/sublime_text)

I also just have access to my home folder so I am locked on version 3176. Can this be fixed?



Got excited for a moment when I saw the dev build 3205 changelog:

  • Linux: Fixed compatibility with old Linux distributions

I tried it out but still failed :frowning: with a different error :

Unable to load                                          
Unable to load gdk_cairo_create from                  
Unable to load gdk_cairo_get_clip_rectangle from      
Unable to load gdk_cursor_new_for_display from        
Unable to load                                             
Unable to load gtk_accel_group_new from                    
Unable to load gtk_accelerator_get_default_mod_mask from   
Unable to load gtk_box_get_type from


Do you not have GTK3 installed?



Unfortunately no. The version of RHEL6 installed on the company servers has: gtk2-2.24.23
Is sublimetext 3200 using anything that is available in gtk3 only?



Yes, ST3200 switched from GTK2 to GTK3 on Linux as it was a long time request of the community.

1 Like


We use functionality added in GTK 3.10, which was released in 2013. We no longer support GTK 2. Users who can’t use GTK 3 should stick with ST 3.1 (build 3176).

Does you company have a migration plan for RHEL 7? It looks like it was released around 5 years ago.


So this isn’t your workstation? What it your workflow for using Sublime Text on a server?



We use a VNC connection to the server farm.
I have sublime available in my /home/ directory (on the server) and run it from there.
It uses whatever libraries are available on the RHEL6 server.

There is a migration plan for RHEL7, but it has been really slow since it requires a lot of verification and validation of tools.

I guess I’ll have to stick with 3176 until they migrate to RHEL7.



I’m in a similar situation - semiconductor industry where we are still on RHEL 6 and RHEL 7+ upgrades for everyone might be a ways off, despite how long ago it was released. RHEL 6/CentOS 6 only provides GTK2, with no easy way to get GTK3.

Will (@wbond), is there a possibility of packaging Sublime Text in a more portable way for old Linux distributions? Either providing an executable with everything statically linked, or using something like Ermine, or packaging Sublime Text as an AppImage or a Snapcraft (used by VS Code) application?

I am not a Linux developer so I’m not well-versed on the technical requirements for each of these options, but one of these might be a way to work around the dependency issues for users who are stuck on older distributions.



There is a snap at



Good to know, thanks. Unfortunately, looks like this won’t help anyone on RHEL/CentOS 6, since Snap is only available on 7.6+ and needs root to install anyways.

I think we’ll all just have to wait for our company to upgrade.