Sublime Forum

4109 always opens a new windows after build?

#1

I’m using win10. After updating to 4109 today, there is always a new window opened every time when I build my latex. This drives me insane.

0 Likes

New window opens with every LaTeX build
New upgrade creates a new instance after each build
#2

Can you clarify how you’re building your latex?

0 Likes

#3

I use the old latexing package, because I never have any issue with it. It was fine all the time until I upgraded to 4109. I think latexing overrides the default build system.

startup, version: 4109 windows x64 channel: dev
executable: /C/xxxxxxx/sublime_text/sublime_text.exe

First, I compile a latex file using the latexing built-in system. Then, a pdf document pops up. After that, a new empty file (with no file extension) pops up, and the cursor moves to this new file. The number of the files increase with the number of compiling times.

0 Likes

#4

Looks like it’s using the Sublime Text executable to focus back on the Sublime Text window. This is fundamentally incompatible with how applications on Windows function, as they’re expected to open a new window when executed. It should be using the command line executable instead. The "keep_focus" setting for latexing can be used to work around this bug.

1 Like

#5

Thanks for your reply. It seems like this setting does not work for this bug. Also, I’m using a portable version.

DPI mode: per-monitor v2
startup, version: 4109 windows x64 channel: dev
executable: /C/xx/softwares/sublime_text/sublime_text.exe
application: /C/xx/softwares/sublime_text
working dir: /C/Users/xx/AppData/Local/Temp
packages path: /C/xx/softwares/sublime_text/Data/Packages
state path: /C/xx/softwares/sublime_text/Data/Local
zip path: /C/xx/softwares/sublime_text/Packages
zip path: /C/xx/softwares/sublime_text/Data/Installed Packages

Now, as a workaround, I downgraded to 4106 while I luckily have a backup.

0 Likes

#6

Make sure you’re setting the setting in the latexing package’s setting (not the global ones), and that you’re setting "keep_focus": true.

0 Likes

#7

Thanks. I did it. I put it in the latexing user settings, but it wouldn’t help.
The weird thing is that everything works properly when I switch back to 4106. So, I’m not sure if 4109 changed how the compile system works.

0 Likes

#8

4109 fixes Sublime Text not acting like other Windows applications. When you click on the taskbar or run it from the windows menu it’s supposed to open a new window. This was fixed in 4109, hence changing the behavior with your plugin.

0 Likes

#9

ok. thanks. I guess I need to find some other workarounds since this change will be permanent.:sweat_smile: Also, we can wait to see if other users have similar issues when using other compilation systems.

0 Likes

#10

I suggest filing an issue with latexing to get them to use the command line tool instead of the main application executable to fix this issue.

0 Likes

#11

For those who may have the same issue, "keep_focus": false solves the problem.

ps: this is not a perfect solution.

0 Likes

Prevent opening a new tab when we launch ST4
#12

I had the same problem with LatexTools. Setting keep_focus = false in the user settings seems to do the job as well!

1 Like