Sublime Forum

Word wrap


without View > Word Wrap on a icon or hotkey, this entire app is useless to me. How can i get Word Wrap accessible?




{ "keys": "ctrl+w"], "command": "toggle_setting", "args": {"setting": "word_wrap"}},

in your “Key Bindings - User” file to toggle it on/off
Here ctrl+w is the keybord shortcut but you can chooose whatever is confenient for you.

and/or put:

"word_wrap": "true",

in your “Settings - User” file to have it active by default.

1 Like


Thank you for the helpful information. I’d been wondering that myself.

A few additional notes: I find the default setting of word_wrap = “auto” fine for most cases (no wrap for source code, wrap for text files). I also find that toggling wrap doesn’t work quite as well as I’d like (with ST 3 build 3059) in that when I turn on wrap the horizontal scrollbar remains and sometimes scrolls way to the right, where no text is visible. Seems like a minor bug. Anyway…it’s nice to be able to toggle it quickly.



Close to 10 years later, this still works. Thank you! :hugs: