Sublime Forum

What happened to my markdown display?!


I rebooted my computer and found that Sublime Text doesn’t apply my theme settings to Markdown files?

Sublime was not doing this yesterday.

I have provided a screenshot of the issue with the questions I wish to ask included in the markdown contents featured in the screenshot.

Can some one help me understand why markdowns are not being given the same theme as the rest of my files?



Settings can be set on a syntax specific basis. It looks like you have Markdown files set to have a specific different color scheme, and in addition the draw_centered setting is enabled for them specifically, which makes the text center in the display (thus giving you the wide margin).

The more obvious culprit for that is MarkdownEditing, which ships with default settings that override the built in Markdown.sublime-settings to include a variety of things, not the least of which is a different color scheme and the centering of the display.

As such you could fix the problem by disabling that package or by choosing Preferences > Settings - Syntax Specific while you have a Markdown file open and manually add in a color_scheme setting and set draw_centered to false to make it more like you might expect.



Thanks @OdatNurd

I attempted to override the MarkdownEditing settings but it wasn’t being accepted for some reason.

Removing that package did restore my theme settings when editing markdown, so I’m in good shape.

Thanks for the tips!



MarkdownEditing 3.0.0 is going to behave better with regards to user settings.



right now I followed this guide to get markdown right on Sublime Text. It is way to turn ST into IA Writer.

BTW @deathaxe. How do I opt-in for the alpha version of Markdown Editing version 3?

EDIT: NVM, I found out quickly. All I had to do was add the package name in the Package Control Settings.



The answer can be found in Markdown Editing User Guide.

1 Like