Sublime Forum

Weird compile error with Latex Tools plugin



I have Sublime Text 2 running on my desktop with the Latex tools working perfectly with Sumatra PDF.
I then tried installing this on my laptop as well, following the same path, but there I always get the following error when I try to compile the document:

\documentclass[5pt,a4paper,oneside]{article} ^ SyntaxError: unexpected character after line continuation character

If I remove this line then the error just comes at the very next line, again pointing at the right parenthesis.

the LaTeX.sublime-build has the following code:

[code]// *** BEGIN MikTeX 2009 ***
“cmd”: “texify”,
“-b”, “-p”,

“path”: “”,
// *** END MikTeX 2009 ***[/code]

I also tried installing TexLive and enabling it instead, but got the same error message.

For comparison I also used the program TeXnicCenter to compile the same .tex documents and got no errors.
Both computers are running Windows 7.

Any help would be appreciated.



I am getting these same errors on OSX. DId you ever figure it out?

Large mistake on my part. Instead of Tools -> Build System -> Automatic I had my build system set to Tools -> Build System -> Ruby from an earlier project.

LaTeXtools is working fine, now.



Just wanted to say thank you.

This solved my (exact same) problem without the need for pulling out my hair.



Thanks!! I was making the same mistake. All works for me now on Mac OS X using ST2 + Skim