Sublime Forum

Upgrade ST4 from ST3 - main toolbar disappeared

#1

I just upgraded to ST4 this morning and the main toolbar with dropdown menus for File, Edit, View, etc. is gone. It’s all available in the hamburger menu icon in the top left of my ST4 window, but I’m looking everywhere for an option to restore the view of the main toolbar, and I cannot find it anywhere.

Is that just gone now in ST4 or do I have to configure a specific setting in my settings file and restart ST4?

2 Likes

#2

You can disable this on the default themes using "themed_title_bar": false. It’s currently lacking some documentation, but the themed title bar requires the menu to be collapsed.

1 Like

#3

That worked like a charm! Thank you for such a quick response.

Yes, it was definitely a bit hidden for me to figure that out on my own. I was ideally looking for an easy option to be available on the “View” menu for a particular toolbar like “Show Menu” or something like that.

In the absence of that option being available, it was definitely harder for me to find in the settings for user preferences. It is worth noting for other users that once I set the “themed_title_bar”: false in my user settings and saved that, ST4 then gets a “Show Menu” option that can be toggled from the “View” dropdown menu.

Also the Alt key is an easy shortcut to toggle the main menu toolbar on/off, but that “themed_title_bar”: false must be set in the user settings or else that “Show Menu” option is completely unavailable as you stated, bschaaf.

1 Like

#4

I have this set. However,I still don’t have the option to show the menu, and “menu_visible”: true also doesn’t do anything.

1 Like

#5

I’m in this boat as well.

0 Likes

#6

I’m just a Sublime Text fan, and not an expert like Benjamin is, so I’m limited in what I can offer you based only on my experience, but my experience this morning was this:

I’m on Windows 10 Pro with the latest updates from Microsoft applied.

I went to Preferences -> Settings from the pancake icon at the top left of my Sublime Text 4 window.

The screen comes up split into two sides: the left side panel is global settings, the right side panel is user settings

If you search for “title” in the left side panel, you will jump to this setting:

// Adaptive theme only: controls if a custom or default title bar is used
"themed_title_bar": true,

You cannot edit it. I believe this default value is what Benjamin was saying comes up by default and depending on whatever theme you are using, if this value is not overriden by you in your personal user settings, that is what causes the pancake icon to appear with all your menu options in the top left corner of Sublime Text 4.

But my experience was that I moved to the right side panel, and entered what Benjamin told me to enter in my personal user settings:

"themed_title_bar": false,

I added the comma at the end of the line because this became the second line in my personal user settings and I had other settings that followed it.

I then had to go up to the pancake icon and select File -> Save to save the changes to my personal user settings.

The instant I did that Save action, it overrode the true setting from the defaults for that same property and the menu bar instantly appeared for me in Sublime Text 4. I didn’t even have to restart the application for the new user setting to take effect.

If this same sequence of actions does not work for you, you have a different situation than I do and you’re going to need more detailed/involved technical support assistance than what I needed.

Best wishes for a successful resolution,
Steve

0 Likes

#7

In addition to setting the preference that @bschaaf specified (and thanks for that!), I found one additional step to be required.

Go to Preferences > Select Theme… My theme was “Adaptive.sublime-theme”. Changing it to either of the Default sublime-theme options immediately restored the menu.

I’m not sure what other effect that theme setting has. I’m using a plugin for syntax highlighting colors and that still works the same…

0 Likes

#8

Thanks Chris! That’s another great point to consider … what theme are you using?

For anyone interested in my specific setup, this is in my user settings:

"theme": "Adaptive.sublime-theme",

That might be the reason why Benjamin’s suggestion worked so easily for me to get my main menu back the way I was used to previously seeing it at the top of my editor window in Sublime Text 3.

0 Likes

#9

I think you need to read my post again because it clearly says that I’ve already done that.

0 Likes

#10

That’s interesting. I’m using the Kronuz theme, but switching to the Default theme does make the menu re-appear.

0 Likes

#11

The instructions to restore the menu bar in Windows worked for me, but after working with the hamburger menu I actually prefer it. For me, just touching alt or clicking the hamburger menu is sufficient and the hamburger menu does clean up the screen for other information in my editing sessions.

0 Likes

#12

wait till you learn to use the command palette. That is Ctrl + Shift + p on Windows or Cmd + Shift + p on Mac. The best method is learning and making your own keyboard shortcuts, but in case you forget, the command palette is the next best thing.

0 Likes