Sublime Forum

Update for SBT 4 does not complete


SBT 4 Build 4113 notified me that an update was available but it hangs and does not complete. I am using Mac OS Big Sur. I have tried 3 times and the result is the same18



What platform are you using? Does it happen every time or just this once?

1 Like


I updated my original post.



5th time worked, thanks for the help to keep trying. That said still odd



It’s not working on Windows 10 either.

  1. Pops up with notice of update, click to download.
  3. Message says ready to install, click to Update.
  4. Goes through some progress, then disappears.
  5. End state: Sublime Text is closed. The installer is closed (at least visibly). Nothing more happens.
  6. Open Sublime Text, and the process starts over at Step 1.

OS is Windows 10 Pro 64-bit, 21H1, all updates. Sublime Text is whatever the latest ST4 version was until today.



Do you have an anti-virus running that could be interfering? Which exact version are you running (Under Help > About)



I don’t have any AV except for the built-in Microsoft Defender.

Sublime Text build is 4113.

Widows build is 19043.1320.

The fifth time didn’t work for me. No number of tries have worked so far – I’m up past ten now. It always just closes and nothing happens.



These are my settings. Also, it’s a licensed install, if that behaves differently:

	"color_scheme": "Packages/Solarized Color Scheme/Solarized (dark).sublime-color-scheme",
	"default_line_ending": "unix",
	"caret_style": "smooth",
	"font_face": "Roboto Mono",
	"font_size": 11,
	"show_encoding": true,
	"show_line_endings": true,
	"theme": "Default.sublime-theme",
	"word_wrap": "true",
	"hardware_acceleration": "opengl",


Is the user account you’re using when starting the update an administrator account?



No, I’m always just in a normal Windows 10 user account – I don’t toggle users or go into an explicit Admin mode.

But because of your question I tried opening Sublime Text as Admin, and it worked. Right-clicking on the Taskbar icon doesn’t offer a “Run as Administrator” option (the way Powershell 7 does), so I tried different keys, and holding down Shift while right-clicking yields lots of options including “Run as administrator”. That worked – it completed the update install. Thanks.

NOTE: It’s my personal machine, not a corporate machine, so it likely has the default user-admin config for the OS. It’s also the default logged-in to Microsoft configuration that they try to force during initial machine setup. I say this because I configured my other machine as a strictly local, non-logged-in to Microsoft user setup (which gets me regular pop-up nudges to log into MS). There are subtle differences in the user-admin behavior in logged-in vs strictly local user setups, but it didn’t matter here. The Sublime Text update failed in exactly the same way on both machines. In any case, it’s not normal to need to go in as Admin to update a Windows app, and many users won’t know how to do it.