Sublime Forum

Undo Disabling Italic


When I switch to this font, “font_style”: “italic” doesn’t work anymore. While using this font, the console says it disabled bold and italic. But I want to show my comments in italic style in codes. But it doesn’t show when I use this font. However, while using Fira Code, Lekton, Hack fonts everything is fine. Can ya help?



As the message indicates, if your font’s Bold and/or Italic font variant does not have characters sized the same as the normal variant of the font (i.e. if they are not a monospace font), then Sublime will disable that font style because otherwise it’s possible that something as simple as adding a single character causes the entire file to visibly shift.

There’s no way that I know of to resolve that other than to use a font that is monospace.