Sublime Forum

Underscores and dots ghost files Mac SamSung SSD



Try to figure out why this happens on Mac.

I have a website project made with Sublime Text saved on the local Mac SSD and all looks normal in Sublime Text.

As soon as I save the same project to my new Samsung external SSD, ghost files, underscored files and dot underscore files appear in Sublime Text when I open that same project from the Samsung SSD.

I know I can remove them with the terminal or a app, but I just wonder is there anything you can do to prevent this from happening.




What file system does the Samsung SSD use? MacOS has resource forks that it can use to store metadata of a variety of types. When stored on file systems that don’t support resource forks (such as the sorts of file systems that are used by Windows) the information from the forks is stored in files that start with ._.



The Samsung SSD is formatted in ExFat. When I copy the project from the disc to desktop the dot underscore stuff doesn’t show. Only when opening a project from the SSD in sublime.



Short of reformatting the disk to HFS or HFS Plus, I don’t think there’s any way to stop the system from storing resource information. Doing so would stop anything non-mac related from being able to access the disk easily though.



I understand that Mac needs the files to store, but my problem is that I don’t want to see them in Sublime text. Is there any setting to make them invisible? They are invisible when opening the same project from the desktop that comes from that SSD.



You can add the patterns for them to the file_exclude_patterns to have them excluded from the sidebar; either in your global preferences or on a project by project basis (but you probably want to go global).

To do that, make sure that you copy the existing default from the left hand pane of the preferences and add in something like "._*" and similar to drop those files out.

1 Like


That’s a simple and good solution! Thanks a lot!