Sublime Forum

UI freeze on startup after upgrade to build 4126


Let me just preface this by saying: “I use arch btw” :stuck_out_tongue:

I am evaluating ST4 to buy a new license (was a paying user of ST3) but unfortunately it seems it’s not working out of the box in my installation.
the UI freezes every time and if i try to close any window it says “window is unresponsive”

It seems to work fine in safe mode, it also seems to insist to open my home directory which shows a lot of files in the sidebar, i only say this because i had a message about adjusting ulimits which I did, but still get the same message.

Any support much appreciated!



ST4 uses user settings of ST3 if available (~/.config/sublime-text-3) in order to carry on all user packages and settings.

Due to amount of changes in core and maybe packages, this may causing your issues. It’s also a bit dangerous, because ST4 may modify packages in ways which drive them unusable with ST3 (in case you want to use them in parallel).

I’d therefore suggest to

  1. manually create a ~/.config/sublime-text folder, which ST4 will use to store all your packages and settings
  2. copy ~/.config/sublime-text-3/Packages/Local/license.sublime_license to ~/.sublime-text/Packages/Local/license.sublime_license
  3. copy ~/.config/sublime-text-3/Packages/User to ~/.config/sublime-text/Packages/User
  4. start ST4
  5. Install Package Control
  6. Let Package Control re-install all packages

Additionally any manually installed or modified package might need to be copied.

By doing so you should have a clean start with ST4 while maintaining all your User preferences and installed packages.




This seem to have helped thanks, to be precise sublime 3 config was under “~/.config/sublime-text-3” (and not directly under $HOME).

Very excited about this new release, and thanks for the all the excellent support!



I think this was meant to be separate statements, but opening your home directory in the side bar could well have been your issue. Sublime needs to scan every folder and subfolder of the folders you open and grab a list of every file, which it would then keep in memory as well as indexcing them to find symbols.

If you open your home directory, that is a lot of load which could easilly make things sluggish and/or appear to freeze things. Starting in safe mode or following the instructions above would essentially remove the session file, which would stop it from trying to index your home directory.



Thank you so much for the thorough response,
i do confirm this is true, i’ve just loaded my $HOME and yeah it’s hanging…

Is there any way to guard against such overload by stopping all processing when filecount passes a certain threshold or depth or something like that? (maybe with like a warning dialog this is happening?)
I can see this occasionally causing trouble in future.



Not that I’m aware of, no. As long as you keep in mind that the file list should be project/task specific and not treated as a file manager, it’s not likely to happen very frequently. You could make a feature request for that (Help > Report a bug from the menu will take you there, if you use ST4) if there isn’t one already though.