Sublime Forum

Ubuntu - Occasional scroll lag


New to using linux as a desktop OS.

Sublime Text 2 w/ EditorConfig, Hex Viewer, Jade, Package Control, Pretty JSON, SCSS, SublimeLinter, Soda, TidyHTML

Sometimes I find that scrolling with the mouse on the preview panel lags considerably behind the mouse movement. If I look at a ‘top’ while doing this I see ‘Xorg’ being listed at 100% for the duration of the scroll. Restarting Sublime does not fix it, but restarting the computer generally does. When I look at top when it isn’t happening I still see Xorg but at a much lower percentage(my sample size for observing all this is 1 though). I’ve tried scrolling a couple of other things, such as a browser, and this doesn’t happen.

Any ideas? I can just restart the machine so this isn’t that big a deal for me.



Any ideas?

Try with ST3.



I’m using Xubuntu 14.04 and Sublime Text v2 and v3 are horribly laggy when I scroll with the scrollbar or preview.

I have “scroll_speed”: 0 set which improved mouse wheel scrolling and I have no issues scrolling in any other application.

Rebooting doesn’t fix it.

Scrolling with the mouse wheel is less laggy but not great.



In addition to what I said above, I’ve found that the amount of lag is directly proportional to the size of the area being scrolled. If I make the window really narrow then it scrolls fast. Also, moving a divider between columns/rows is super laggy too. Selecting text is also very laggy.



I’ll do some experimenting next time it happens and see if my results are the same as yours



Okay, I get the same action as you do ( speeds up when I make the window narrow ).

Do you get the CPU usage in the Xorg process?

The command line for my Xorg process is /usr/bin/X-core:0-seatseat0-auth/var/run/lightdm/root/:0-nolistentcpvt7-novtswitch

Rebooting still fixes mine, thankfully. I haven’t tried ST3 yet, to be honest I’d rather not upgrade until it leaves beta.



I have an nvidia 460m and am running driver version 331.38. They seem to have 331.79 out so I may try that.



There’s a good chance that means “never”.



same problem here. :frowning:



I am experiencing the exact same problems using the latest build of ST3. On my Laptop, there are no problems (using a resolution of 1377x786), but on my desktop pc using full hd resolution it lags a lot. As mentioned above, I also do not have scroll lags when using other applications with the Gtk2/Gtk3 window framework (I am using Gentoo GNU/Linux on both computers).
Shrinking the window helped.

I can confirm everything of what he said.

Did you find any solution to that?

Kind regards,



This is mostly a “me too” post.

I’ve upgraded to Fedora 21. When Sublime Text 3 (build 3065) is on the screen backed by the ATI card smooth scrooling is terribly slow and text selection is laggy, as described above. When Sublime Text is on the screen where the Intel driver is in use the graphical behavior is normal.

Sublime Text is the only application showing this behavior. Firefox, Thunderbird, and xfce-terminal do not exhibit this behavior.

I’ve turned off smooth scrolling and animations, but the lag is still distracting.

Fedora 20 did not show this behavior. May I suggest it might be related to glamor, but I have no proof for that.



For any interested, I’ve much-improved the situation on Fedora 21 by explicitly enabling Glamor acceleration. The relevant section of my /etc/X11/xorg.conf.d/10-xinerama.conf file is:

Section "Device"
    Identifier     "Device0"
    Driver         "radeon"
    Option         "AccelMethod"    "glamor"
    VendorName     "AMD Radeon"
    BusID          "PCI:1:0:0"

Perhaps that will help someone?



Ubuntu Gnome 15.04 with Gnome Shell 3.14.4 and Sublime Text 3 here

I had that occasional scroll lag after PC and OS upgrade, more precisely on scroll start most of the times. And although it might sound like a minor issue, it was very annoying because after the initial lag/jump on mouse scroll I almost all of the time was loosing focus on the text I was looking at.

Anyway, in case you have Nvidia VGA, that utilizes PowerMizer to down-clock itself, you should disable that feature:

Each time your VGA goes to Level 0, it needs to up-clock itself to the higher level when you scroll in Sublime Text. This is where the lag occurs. Of course disabling PowerMizer will drain your laptop battery faster and also the VGA will run hotter even when idle. In my case the temperature raised from 33C to 40C, but in my case the fan remained in silent mode, also I’m on desktop workstation so the power consumption is not a big problem.



5 years later and this is still an issue! Ubuntu 18.04, ST3 build 3211, RTX 2080 Super. I spent HOURS trying different things including switching graphics drivers, but this was the fix! My GPU has jumped 15-20° but it’s smooth scrolling and I couldn’t be happier!