Sublime Forum

Turn off auto_complete, but just for txt, not for html?


I like auto_complete a lot when editing html documents, but in normal text documents I want to turn it off, is that possible and how?



The setting "auto_complete_selector" controls where auto-complete is used. Do note the default is to not have auto-complete inside text or comments.



I can’t figure that option out. It’s default setting here is

“auto_complete_selector”: “meta.tag - punctuation.definition.tag.begin, source - comment - string.quoted.double.block - string.quoted.single.block - string.unquoted.heredoc”,

No plaintext there, or am I blind?



Correct, it isn’t part of the default auto_complete_selector. Means auto completion doesn’t trigger while typing in text by default. You may still hit ctrl+space to trigger it manually though.

Auto completion is enabled for source with some exceptions and meta.tag (html) only, by default.

But I need to mension - not sure whether it is intended or a bug - auto completion still triggers in text files under certain circumstances. I can type “l” and hit tab (with "tab_completion": true, - which is by default) to display the auto-completion panel with lorem ipsum being sugested in ST4099. Same happens for word completions. It appears tab_completion even ignores auto_complete: false.



Yep, fully agree to all you wrote. I had to disable tab_completion to turn it off. Weird.