Sublime Forum

Too many autocompletes at once

#1

Lately (perhaps the last month or two), when I’m typing in css or html, I’m getting an extra autocomplete popup on top of my regular autocomplete. It looks like this:

Where the green autocomplete is the one I don’t want. But when I hit “tab” to select the normal autocompleted option (in this case, the blue one), the green one gets filled in instead. The green one is almost never useful.

This is probably a plugin I’ve installed, but I’ve disabled a bunch of them, and I can’t figure out which it is. Does anyone know how to get rid of that?

0 Likes

#2

It’s a feature of the Emmet package, see the README:

If you don’t like inline preview for CSS, you can disable it for CSS only:

  • Go to Preferences > Package Settings > Emmet > Settings menu item.
  • Set abbreviation_preview option to "markup" , e.g. "abbreviation_preview": "markup" . This will enable previews for markup syntaxes (HTML, XML, JSX etc.) only.
  • You can also disable previews completely by setting abbreviation_preview value to false .
0 Likes