Sublime Forum

The save file operation failed


With the latest update I’ve been getting this error frequently enough to be annoying.

What if anything can be done?



Have you tried reverting to a freshly installed state?
Which version of macOS and which version of Sublime Text are you using?



I came upon the same issue and can provide some more context:

Steps to reproduce:

  1. Open an existing file with .html.eex extension (syntax is “HTML (EEx)”)
  2. Copy everything in it (as text)
  3. Create a new blank file, paste
  4. Try to save - editor freezes for ~10s, displaying the message “The save file operation failed” as mentioned above

Does not happen with files of Markdown, Plain text or some of the other types/syntaxes I tried with.
Sublime console remains silent.
Workaround so far is to insert an extra step between 2 and 3 - paste into another text editor, and copy it from there (thus it carries no contextual information into sublime).

I am with Sublime text 3.2.2 (3211) on MacOS 10.15.1



v3.2.2 build 3211

Same issue for yaml files. Currently just changing the text review thingy from yaml to plain text and then saving. Here is a video: The screen recording doesn’t show the spinning beach ball.



macos catalina 10.15.3 (19D76)

sublime text v3.2.2 build 3211

just ran into the same issue, but with HTML Jinja2 files (.html.j2)

try to save a new file with HTML Jinja2 syntax on, get spinning beach ball, then failure

change to any other syntax and try to save and it works fine, saving already created files with HTML Jinja2 syntax on works fine

I seem to have no problems saving new file with yaml syntax or any other syntax I currently have at my disposal tho :confused:

Edit: thought occurred to me, could this be some kind of macos catalina permissions issue, plaguing user installed syntaxes? :thinking: