Sublime Forum

Terminus + Vintage - How start shell view with vintage in insert mode

#1

Summary

I don’t know how to change general/core sublime settings specifically for when I’m using Terminus

Problem

I use the terminus terminal simulator all the time (thanks randy3k!!)

Also using default/built-in Vintage package (for vim keybindings)

When I open a terminus shell in view (i.e., not in the panel), I would like to have vintage start in insert mode.

I set "vintage_start_in_command_mode": true in my User Preferences, but would like to override this specifically for terminus.

Reason/Purpose

My reason for this being that I have vim keybindings set up for my terminal work, and I’d rather not disrupt them for when I am doing shell work outside of sublime. Moreover, the way typing in Terminus works is through keybindings, which entirely disrupts vintage, which makes relying on keybindings at the shell level even more sensible.

Attempts

I’ve tried putting "vintage_start_in_command_mode": false in my User/Terminus/sublime-settings file, which appears to have no effect.

Do general / core settings not operate there (or in any package settings files)?

I’ve confirmed that "vintage_start_in_command_mode": false in my general User settings and syntax specific settings files works as expected (this is my current work around)

Incidentally, I’ve noticed that I can’t pull out any of the settings operating in a Terminus view using view.settings().get() in the console. I don’t know what that means.

I am not aware of any way that I can use syntax specific settings that are specific to Terminus.

Is there any way to adjust genera/core sublime settings while using Terminus?

0 Likes

#2

@maegul

Putting vintage_start_in_command_mode in Terminus settings is not working because the setting value of vintage_start_in_command_mode is checked when the view is loaded and Terminus applies these view settings after the view is loaded.

Basically, you want to disable command_mode as a whole. Try this

	"view_settings":
	{
		"command_mode": false,
		"inverse_caret_state": false
	}

Update: These settings are now applied to the Terminus view in default - https://github.com/randy3k/Terminus/commit/12d42978e3287bc95d7ec107bd5dc4d1789dfc4e
Just wait for the next release, or fetch the master branch from github.

1 Like