Sublime Forum

Tabs to spaces preferences not respected in v3.2.2 3211


I opened an HTML file and immediately noticed the indentation was wrong.

I selected everything, and pressed Shift+Tab until everything was aligned the left-most column.

I then started highlighting rows of text and pressing Tab, and it will shift over by two spaces. I have the following Preferences. There are no syntax-specific preferences set.

“tab_size”: 4,
“translate_tabs_to_spaces”: false

Please tell me why and how I can correct this. I want tabs, not spaces. I want the tab size to be 4 spaces long.



Sublime Text will auto-detect indentation by default. The "tab_size" and "translate_tabs_to_spaces" settings are used when it can’t detect the indentation. If you want to convert the indentation use the menu View > Indentation > Convert Indentation to Tabs or the command Indentation: Convert to Tabs. If you don’t want to use automatic indentation detection use "detect_indentation": false. Note you will still have to convert indentation to your desired style when opening a file.