Sublime Forum

Tab key does not work with javascript syntax selected


For some reason I cannot tab in sublime text when using javascript syntax highlighting. Tab inserts fine if I select any other language, it’s just specifically javascript. Even if I select JSON, tab key works just fine.

If I select a whole line or multiple lines it will tab them over just fine. If I select text and hit tab, it will overwrite that text, but if I just hit tab with nothing selected, it does nothing. Shift+tab will unindent a line just fine.

I cannot figure this out. It just doesn’t work today. I’m pretty sure it was working fine two days ago when I last used it.



This sounds suspiciously like a key binding that’s been set to override the default functionality. A reason for that could be a package that you just installed (or which was just updated), but this can also happen if you add a custom key binding to do something without realizing that it’s going to apply in more situations than you might have intended.

Have you added or tweaked any custom key bindings lately?



No new packages or anything. Haven’t touch a config in months. I’m guessing something got nuked. My laptop battery dies often enough, so maybe it took something with it. I tried removing all the packages and that didn’t work, so I just removed sublime completely and installed everything fresh again and now it works fine.