Sublime Forum

SublimeText3 consistently freezes

#1

I’m running version 3206 OSX. I am unsure what is going on. But after 5 minutes or so, SublimeText3 freezes consistently. I can’t do anything with it, and need to Command+Q it then re-open it. I have gone so far as to completely uninstall it (deleting files in Application Support folder) and running it clean (no added packages). But, even after that, it continues to freeze on me. occasionally I do see an empty white box on screen. This started happening a few updates ago.

I would prefer to use SublimeText (I paid for it), but now I’m having to use Atom. Are there any tips to debug why this is happening? or is it a known issue?

1 Like

#2

Same here, running Build 2307 on Mojave 10.14.4 (18E226).
After enough tries it eventually loads, but still drags and I’ve freezes while writing.

Started happening after I ran an update earlier today.

Not sure if it has anything to do with it, but this happens while hooked to an external GPU, I’m going to test without the GPU soon.

0 Likes

#3

I have a similar issue on the mac as well. For me, it started after the first release with the git integration. The most recent update hasn’t seem to have helped. I’ve noticed this mostly after sleeping/waking sublime text has either crashed or it is not responsive.

0 Likes

#4

Good connection, I believe it does have something to do with the git integration.

0 Likes

#5

Same for me, is there a way to go back to the previous version 3200 ?

0 Likes

#6

Change the version number in the download link to any version that you want.

0 Likes

#7

Similar problem here. Linux 5.0.7 x86_64. Build 3207.

Editor freezes from time to time. Have to restart it every time.
I love the editor and want to pay for it, but this freezing issue is extremely annoying.

Sandboxing it doesn’t make a difference.

0 Likes

#8

If you are on macOS 10.14.4, please see Crash or Memory Leak on macOS Mojave 10.14.4?.

If you are seeing freezes otherwise, please try and see if the issue continues in a freshly installed state. https://www.sublimetext.com/docs/3/revert.html

0 Likes

#9

Hi. I tried the “gpu_window_buffer”: false, fix and also reverted to a freshly installed state.
The freeze continues.
Build 3207
macOS Mojave 10.14.5

0 Likes

#10

I have been having same issue (although on Linux). I am on a laptop, and seem to always have the problem when using trackpad, but when I dock my laptop (and use a trackball) never have an issue. Tried lots of stuff including reverting sublime to fresh installed state with no resolve, but now found smooth scrolling setting, turning that off in sublime solved it for me. On build 3210.

“scroll_speed”: 0,

0 Likes

#11

I had to go into settings -> energy saver, and disable “automatic graphics switching” to fix it. But, now that I’m on Catalina, the problem has gone away.

0 Likes

#12

Same problem on OSX High Sierra and SBT3 build 3211. Any idea how to solve it?

update: the freezing occurs whenever i connect my laptop to my screen. I tried setting “gpu_window_buffer” to false but it does not help.

0 Likes

#13

Windows 10 user. Version 3.2.2 Build 3211
Yep.Just bought the software today. Love it all other areas but freezing (white screen faded text) 20 times today. I can wait it out or force close to continue. I’m surprised as it looks like such a well thought out piece of software in every other aspect.

0 Likes

#14

So it just suddenly happens?


By the way, since you have a ST 3 license, you may want to try ST4’s dev builds which are available on the Discord chat server https://discord.gg/D43Pecu

0 Likes