Sublime Forum

Sublime Text 4 Snippets problem

#1

Hi

After upgrading to Sublime Text 4 snippets became unusable.

The snippets are not showing up in autocomplete. And can only be invoked when autocomplete popup disappears.
So far I’ve deleted all customizations (everything Application Support/Sublime Text 3) reinstalled sublime text with brew and have a clean Sublime Text 4 on my Mac. I’ve tried to toggle all the snippet-related settings. I’ve tried to copy settings from the safe mode and put it as user-defined settings in the regular mode.

Snippets work just fine in safe mode.

Help pls, this breaks my workflows big time.

0 Likes

#2

If it works in Safe Mode, then some package that you have installed (or something in your User folder) is getting in the way of the AC system; Safe Mode replicates a truly “clean” Sublime Text configuration.

I’m not sure what that might be based on what you outlined above. Have you tried installing with the downloads from the page instead of using brew?

0 Likes

#3

If you installed a plugin SublimeCodeIntel, try to disable it.

0 Likes

#4

I uninstalled everything and deleted everything from the User folder.

0 Likes

#5

package control malfunctions too… this is fucked up, guys, why would you enforce this update at all? I was completely happy with st3 tailored to my needs.

1 Like

#6

it looks ok! thanks

0 Likes

#7

So Snippets don’t work in Sublime Text 4 at all, am I getting this right? What a bummer, it’s such an essential feature :frowning:

0 Likes

#8

No, snippets work just fine in ST4 (in fact, in my recent live streams we’ve been working on a plugin to augment the default functionality).

In what way are you seeing them not working?

As outlined above, the first thing to check is Safe Mode to see if things work there as you expect. If so, then your problem is related to a setting or a package that is interfering.

1 Like