Sublime Forum

Sublime stopped launching on big sur


I have a new MBP running os x 11.6. My system was loaded from my old, 2016 MBP. Sublime 3 (I believe) ran but without my preferences, which had not been copied. I updated them and got my familiar edit settings back. This worked fine for a few weeks until today, or perhaps until a recent reboot - not sure.

Now, sublime 3 wont launch. I tried to download and launch, same problem. I removed all versions of the app and downloaded sublime 4. Also wont launch.

Or rather, it launches, according to Activity Monitor, but it never makes a window. After maybe 20 seconds, it disappears from Activity Monitor. I searched here and found the off-screen problem, but when I use the key to see a mini version of all windows, while the Sublime is (briefly) running according to the Activity Monitor, there is no window.

What happened?! Is there some other way to install?



It’s working just like before on macOS 11.6 for me. Is it able to launch in safe mode?



Curious, do you see any errors when launching via (change paths to location of ST if needed):

  1. open -a /Applications/Sublime\
  2. /Applications/Sublime\

If there are no errors, you can check the Console app to see if any errors are reported there. (search for sublime_text, then change ANY to Process)

note: change sublime_text to Sublime Text for ST3



Thank you for reminding me of safe mode - I knew about it years ago but forgot.

I got console messages that way. Not sure what I did yesterday to convince myself there were none, as they show up for the icon version as well.

I searched for errors and found reference to WSDaemon, which is part of Webroot, which I officially loathe. Interestingly, running it from the command line

Fortunately, I had instructions from IT for disabling it for a different problem, so I did that and voila! Sublime starts up perfection, command line or in the editor.

In case it helps anyone else, I did this, in a root shell:
sudo /Applications/Webroot\ -u

I’m sure it will come back on reboot. Maybe there is a way to tell it that sublime is benign and important to me! I’ll make that IT’s problem though.



Hey, thanks for it.



I got this error too. And I find some error log from system.log

Oct 13 16:21:33 sublime_text[24384]: getattrlist failed for /System/Library/Extensions/AppleIntelKBLGraphicsGLDriver.bundle/Contents/MacOS/AppleIntelKBLGraphicsGLDriver: #2: No such file or directory
Oct 13 16:21:34 sublime_text[24384]: getattrlist failed for /System/Library/Frameworks/OpenGL.framework/Resources//GLRendererFloat.bundle/GLRendererFloat: #2: No such file or directory

Is any one has any ideas about that ?