Sublime Forum

Sublime Merge UI fonts illegible

#1

Hello I’m using the latest ubuntu with gnome 3. The below happened after a reboot and I have no idea why, or where to start to investigate. Any pointers? Any settings file to reset? Or font to config?

TRIED:

  1. rm -rf .config/sublime-merge
  2. remove from snap, install from deb

None helped, it looks the same

0 Likes

#2

Which version of Sublime Merge are you using? Which version of Ubuntu? Does this happen after every reboot?

0 Likes

#3

sublime-merge_build-1119_amd64.deb

I’m using Focal 20.04, which is not a GA version of Ubuntu, but every other program works well, including Sublime Text:

image

Reboots won’t help. Rebooted and updated the system already a few times from apt.

NB: This used to work, then it became like this after some time I used it, and I have no idea. That’s why I was trying to reset the configuration state.

0 Likes

#4

Are you using display scaling of any kind? Can you also try reverting sublime-text?

0 Likes

#5

No scaling at all, always ran at native resolution. What doyou mean revert sublime text?

0 Likes

#6

https://www.sublimetext.com/docs/3/revert.html

0 Likes

#7

If you move the .config/sublime-text-3 directory that will revert Sublime Text to a freshly installed state.

0 Likes

#8

Yes, you nailed it. Reverting Sublime text triggered the issue (see the tab title!)

image

Actually now that I think about it, the previous screenshot did not show anything in the tab title, maybe the issue was there before too, and I didn’t notice.

0 Likes

#9

I was actually trying to fix Sublime Merge :frowning:

I don’t have the faintest idea what it could be, I’ll try to reproduce on your distribution when I get the chance.

0 Likes

#10

What do you have the font sans mapped to? That is what we use for tab names in Sublime Text and general interface text in Merge.

0 Likes

#11

The fonts configured in my system can be seen in the screenshot I sent above “Sans Regular 12”. It’s a view from Gnome Tweaks (regular settings don’t let you see/control fonts)

0 Likes

#12

I’m no expert in font config, so it isn’t clear to me that any of those set the “Sans” alias in font config.

Could you run this an paste the output?

fc-match -s sans
1 Like

#13

I think you hit the nail on the head with this. As you can see, the first of the list is a Emojii font I had to install to see emoji in Chrome. It’s totally wrong that it comes up as first choice for “sans”. Where is this declared?

$ fc-match -s sans |head
NotoColorEmoji.ttf: "Noto Color Emoji" "Regular"
DejaVuSans.ttf: "DejaVu Sans" "Book"
DejaVuSans-Bold.ttf: "DejaVu Sans" "Bold"

UPDATE: I followed a crappy guide to fix emoji in chrome that instructed to have this file in place:

$ cd && cat  .config/fontconfig/fonts.conf
<fontconfig>
<match>
<test name="family">
<string>sans-serif</string>
</test>
<edit name="family" mode="prepend" binding="strong">
<string>Noto Color Emoji</string>
</edit>
</match>
<match>
<test name="family">
<string>serif</string>
</test>
<edit name="family" mode="prepend" binding="strong">
<string>Noto Color Emoji</string>
</edit>
</match>
<match>
<test name="family">
<string>Apple Color Emoji</string>
</test>
<edit name="family" mode="prepend" binding="strong">
<string>Noto Color Emoji</string>
</edit>
</match>
</fontconfig>

which results in sans bein alias for the Emoji font (which is inintelligible). And breaking sublime-*.
Fixed with removing the file and calling:

fc-cache -f -v

Thank you @wbond, and others for the precious help, you rock! :rocket:

1 Like

#14

Glad you got it sorted!

1 Like