Sublime Forum

Sublime Merge is always asking for credentials / Win 10

#1

Hello,

I am new to Sublime Merge and was using Github Desktop before.

The program asks every time for my Github credentials on push or pull.
Github Desktop does not, it seems this is stored in the program.
But I cannot find any location where these credentials can be stored in Sublime Merge.
So I assume this must be somewhere else. But I cannot find any documentation on this.
Without this remote functionality the program is useless for me.

After push a Github credential popup opens. I write down my credentials. Popup closes.
Popup opens again. I input my credentials again. Popup closes.
Now a black popup opens (from Sublime Merge) and asks for Github username.
After that another popup opens and asks for my Github password.
After that the push is done successfully.

But these credentials are not stored. After the next pull or push this annoying procedure begins again and again and again.

My remote origin is set to
remote.origin.url=https://github.com/myrepo/xyz.git

What can I do to get the connection working withuot putting always multiple times my credentials? Thanks.

Kind regards
Chris

1 Like

#2

Hi @Treebeard,

Thank you for sharing this question.

I would suggest using WinCred, which will store your GitHub credentials in the standard Windows Credential Manager. To do this, run the following from the command line:

git config --global credential.helper wincred

The next time you authenticate, it should store your credentials in the Windows Credential Manager for future use.

Let me know if this helps.

Kind regards,
- Dylan

0 Likes

#3

Hi Dylan,

thank you very much for your response.

This solves a small part. The two single credential windows for separate asking username and password dissapeared after once putting these into the popup.

What remains is the popup which opens in command line once (while pulling from Github) and from Sublime Merge two times (while pulling here).

Maybe this information helps:

git config -l

http.sslcainfo=C:/Program Files/Git/mingw64/ssl/certs/ca-bundle.crt
http.sslbackend=openssl
diff.astextplain.textconv=astextplain
filter.lfs.clean=git-lfs clean – %f
filter.lfs.smudge=git-lfs smudge – %f
filter.lfs.process=git-lfs filter-process
filter.lfs.required=true
credential.helper=manager
core.autocrlf=true
core.fscache=true
core.symlinks=false
core.editor=“C:\Program Files\Sublime Text 3\subl.exe” -w
core.autocrlf=true
core.excludesfile=C:\Users\Chris\Documents\gitignore_global.txt
core.editor=‘C:\Program Files\Sublime Text 3\sublime_text.exe’ -w
user.name=Chris XXXX
user.email=xxxxxxxxx@xxxxxx.de
difftool.sourcetree.cmd=‘C:/Program Files/Beyond Compare 4/BComp.exe’ “$LOCAL” “$REMOTE”
mergetool.sourcetree.cmd=‘C:/Program Files/Beyond Compare 4/BComp.exe’ “$LOCAL” “$REMOTE” “$BASE” -o “$MERGED”
mergetool.sourcetree.trustexitcode=true
filter.lfs.smudge=git-lfs smudge – %f
filter.lfs.process=git-lfs filter-process
filter.lfs.required=true
filter.lfs.clean=git-lfs clean – %f
credential.helper=wincred
core.repositoryformatversion=0
core.filemode=false
core.bare=false
core.logallrefupdates=true
core.symlinks=false
core.ignorecase=true
submodule.active=.
remote.origin.url=https://github.com/xxxxxxxx/xxxxxxx.git
remote.origin.fetch=+refs/heads/:refs/remotes/origin/
branch.master.remote=origin
branch.master.merge=refs/heads/master
branch.dev.remote=origin
branch.dev.merge=refs/heads/dev
branch.dev_1768.remote=origin
branch.dev_1768.merge=refs/heads/dev_1768
branch.USA_dev.remote=origin
branch.USA_dev.merge=refs/heads/USA_dev
branch.dev_1768_US.remote=origin
branch.dev_1768_US.merge=refs/heads/dev_1768_US

Kind regards
Chris

0 Likes

#4

Hi everybody,

any ideas how to remove the popup?
I still have two times oping the popups from Github asking for credentials.

Kind regards
Chris

0 Likes

#5

Hi @Treebeard,

Would you mind sharing a screenshot of this dialog you are seeing?

Additionally, would you mind sharing your debug information of the repository in question via Sublime Merge? This can be accessed via Help > Debug Information. (Before sharing, feel free to remove any information you feel is sensitive).

Thanks,
- Dylan

0 Likes

#6

Hi Dylan,

thanks for your help again. Yes of course, here you can see the dialog:
2021-03-04%2022_12_13-Sublime%20Merge%20is%20always%20asking%20for%20credentials%20_%20Win%2010%20-%20Sublime%20Merge%20-%20Sublim

This is the Debug info:
=== App Version Information ===
Build: 2047

=== Git Version Information ===
Using Git: C:\Program Files\Sublime Merge\Git\cmd\git.exe (bundled)
git version 2.29.2.windows.2
PATH: C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\Program Files (x86)\Intel\iCLS Client;C:\ProgramData\Oracle\Java\javapath;C:\Program Files\Intel\iCLS Client;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0;C:\Program Files (x86)\Common Files\Acronis\SnapAPI;C:\Program Files (x86)\GNU\GnuPG\pub;c:\Ruby22-x64\bin;C:\Program Files (x86)\Common Files\Acronis\VirtualFile;C:\Program Files (x86)\Common Files\Acronis\VirtualFile64;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0;C:\Program Files (x86)\Skype\Phone;C:\Program Files\OpenSSH\bin;C:\Program Files\dotnet;C:\WINDOWS\System32\OpenSSH;V:\xampp\php;C:\ProgramData\ComposerSetup\bin;C:\Program Files (x86)\Intel\Intel® Management Engine Components\DAL;C:\Program Files\Intel\Intel® Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel® Management Engine Components\IPT;C:\Program Files\Intel\Intel® Management Engine Components\IPT;C:\Program Files (x86)\HP\Common\HPDestPlgIn;C:\Program Files (x86)\HP\IdrsOCR_15.4.1132.0;C:\Program Files\Git\cmd;C:\Program Files\nodejs;C:\ProgramData\Oracle\Java\javapath;C:\Program Files (x86)\Intel\iCLS Client;C:\Program Files\Intel\iCLS Client;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0;C:\Program Files (x86)\Common Files\Acronis\SnapAPI;C:\Program Files (x86)\GNU\GnuPG\pub;C:\Program Files (x86)\Intel\Intel® Management Engine Components\DAL;C:\Program Files\Intel\Intel® Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel® Management Engine Components\IPT;C:\Program Files\Intel\Intel® Management Engine Components\IPT;c:\Ruby22-x64\bin;C:\Program Files (x86)\Common Files\Acronis\VirtualFile;C:\Program Files (x86)\Common Files\Acronis\VirtualFile64;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0;C:\Program Files (x86)\Skype\Phone;C:\Program Files\OpenSSH\bin;C:\Program Files\nodejs;C:\Program Files\dotnet;C:\Program Files (x86)\Windows Kits\8.1\Win

=== Browse Page Information ===
HEAD: 5e6e507e435d38df29f7f5795476e35ec4f116f1
Is in merge: 0
Is in cherry_pick: 0
Is in rebase: 0
Is in revert: 0

=== Git Status Information ===

=== Our Status Information ===

=== Git Config Information ===
branch.USA_dev.merge=refs/heads/USA_dev
branch.USA_dev.remote=origin
branch.dev.merge=refs/heads/dev
branch.dev.remote=origin
branch.dev_1768.merge=refs/heads/dev_1768
branch.dev_1768.remote=origin
branch.dev_1768_US.merge=refs/heads/dev_1768_US
branch.dev_1768_US.remote=origin
branch.master.merge=refs/heads/master
branch.master.remote=origin
color.branch=auto
color.diff=auto
color.interactive=true
color.status=auto
core.autocrlf=true
core.bare=false
core.editor=‘C:\Program Files\Sublime Text 3\sublime_text.exe’ -w
core.excludesfile=C:\Users\Chris\Documents\gitignore_global.txt
core.filemode=false
core.fscache=true
core.ignorecase=true
core.logallrefupdates=true
core.repositoryformatversion=0
core.symlinks=false
credential.helper=wincred
diff.astextplain.textconv=astextplain
difftool.sourcetree.cmd=‘C:/Program Files/Beyond Compare 4/BComp.exe’ “$LOCAL” “$REMOTE”
filter.lfs.clean=git-lfs clean – %f
filter.lfs.process=git-lfs filter-process
filter.lfs.required=true
filter.lfs.smudge=git-lfs smudge – %f
help.format=html
http.sslbackend=openssl
http.sslcainfo=C:/Program Files/Git/mingw64/ssl/certs/ca-bundle.crt
include.path=C:/Program Files/Git/etc/gitconfig
mergetool.sourcetree.cmd=‘C:/Program Files/Beyond Compare 4/BComp.exe’ “$LOCAL” “$REMOTE” “$BASE” -o “$MERGED”
mergetool.sourcetree.trustexitcode=true
pack.packsizelimit=2g
rebase.autosquash=true
remote.origin.fetch=+refs/heads/:refs/remotes/origin/
remote.origin.url=https://github.com/xxxxxxxx/xxxxxxx.git
submodule.active=.
user.email=xxxxxxxxx@xxxxxx.de
user.name=Chris XXXX

=== Our Config Information ===
Git Config Path Information
Using config path: /C/ProgramData/Git/config
Using config path: /C/Program Files/Sublime Merge/Git/etc/gitconfig
Using config path: /C/Users/Chris/.config/git/config
Using config path: /C/Users/Chris/.gitconfig
Using config path: /V/xampp/htdocs/tnt_master/.git/config

Our config output is identical to the Git config output

=== Git Attributes Information ===
git check_attr --all output

=== Our Modified Files Newline Normalisation and EOL Information ===

=== Our Modified Files Flag Information ===
Ignoring symlinks: 1

Thanks
Chris

0 Likes

#7

Hi @Treebeard,

That looks as if you’re being presented with the outdated GitHub Login credential helper.
I believe GitHub deprecated that recently.

Could you try the following:

  1. Open the terminal, and navigate to the repository you are having issues using
  2. Run git config credential.helper manager-core
  3. Run git config credential.gitHubAuthModes oauth

The next time you run a push/pull/clone you should be presented with the sign in dialog shown below: Sign%20In

From here, you should select the Sign in with your browser option, and follow the instructions shown.
Once you’ve authenticated, it should cache your credentials and you shouldn’t have to input them again.

Let me know how this goes.

Kind regards,
- Dylan

0 Likes

#8

Hi Dylan,

thanks for your help again. I did all 3 steps, but still it is showing this dialog:

After canceling this I have seen this message:
*** Image removed due to restrictions ***

Logon failed, use ctrl+c to cancel basic credential prompt.
git: ‘credential-manager-core’ is not a git command. See ‘git --help’.
Already up to date.

I tried to locate the credential-maanger-core:
*** Image removed due to restrictions ***

I asked Ecosia for that issue and followed some links to download and (re?)install Git-Credential-Manager-Core and downloaded a version for Microsoft Windows.

I still got the error, but now the dialog does not show again and pull/push works on command line and also in Sublime merge. This makes me very happy. Thanks for your help.

Kind regards
Chris

0 Likes

#9

0 Likes

#10

These are the images for the post above^^

0 Likes