Sublime Forum

Sublime Merge build 2091 won't start on Win 11 64-bit


After the last update to 2091 Sublime Merge won’t start on my Win 11 64-bit system.

When opening, it appears in task manager for a second and then it disappears. I tried multiple reinstalls with no luck, then I reverted to 2083 which runs fine.



If re-installing doesn’t change anything the reason is most likely related with user profile data.

I’d suggest to clear syntax cache as a first step:

  1. Navigate to %LOCALAPPDATA%\Sublime Merge\
  2. Delete Cache directory.

If that’s not enough you may also want to check session file or other files located in %APPDATA%\Sublime Merge\.

1 Like


Thank you, still doesn’t want to run.

I updated to 2091, cleaned the cache and Sublime Merge started.Then I closed it, but it wouldn’t start again.

Next I deleted session files from %APPDATA%\Sublime Merge\Local, but it didn’t help.



I am running both ST and SM without such issues on Win11.

Sublime Merge also loads packages from a Sublime Text, if installed.

Maybe one of those packages is causing trouble.

To verify that you could close ST and temporarily rename %APPDATA%\Sublime Text so SM doesn’t see them and re-try again with cache folder deleted.



Hi @BoomBadill,

Thanks for reaching out. Could you confirm if this is occurring on a public repository?
If so, would you mind sharing this repository.

Additionally, could you confirm if you have hardware rendering enabled?

You can do this by opening the Sublime Merge preferences in the application menu (in build 2083), navigating to the Advanced section, and checking the Hardware Rendering preference.

If this is enabled, could you try disabling this and see if this resolves the issue in 2091?

- Dylan from Sublime HQ



Hi @djohnston,

Thanks for getting back. Repository is private unfortunately. Hardware rendering is disabled.

I tried this:

  1. closed 2083 and deleted session files
  2. opened 2083, it started with a Open/Clone repository dialog, no repository was open in SM
  3. updated to 2091, it wouldn’t start

Today after the first bootup and first update attempt, version 2091 did start automatically and I was able to open all of my local repositories, but as soon as I closed SM, I couldn’t open it again. Same happened the first day I noticed the problem. I tried to reproduce this behavior, restarted the computer, turned it off for a few minutes, but I couldn’t get it to happen again.

Thank you.



Do you have an anti-virus or similar that could be interfering?

1 Like


Hi @bschaaf,

sorry for the late reply. Yes, issue was related to anti-virus. My computer is managed by my company, so they added an exception for SM and now it works as expected.

Thank you all for the suggestions and help.

1 Like