Sublime Forum

Sublime 4: scrolling not smooth

#21

I just recorded another video where you can clearly see that I have the hardware rendering enabled but it’s capped on 60fps when I’m scrolling. My monitor is running at 144Hz at the time of the recording. Also in my previous video you can see that with the software rendering it goes up to 144fps when I’m scrolling.

0 Likes

#22

We use the standard gtk_widget_add_tick_callback on Linux to schedule animations. If that’s not giving us the frame rate of the monitor then that seems like an issue with GTK or your desktop environment. I’m not getting the same behavior here so perhaps it’s already been fixed in a later version of GTK.

1 Like

#23

@bschaaf Sorry, I completely missed your last message.
Running 4126 Stable on Monterey, issue persists.

fps: 10.9 average: 0ms
fps: 16 average: 0ms
fps: 15.9 average: 0ms
fps: 15.9 average: 0ms
fps: 16.5 average: 1ms
fps: 14.9 average: 1ms
fps: 14 average: 1ms
fps: 14.9 average: 1ms
fps: 14.9 average: 1ms
fps: 15 average: 1ms
fps: 15 average: 1ms
fps: 42.9 average: 2ms  - began scrolling
fps: 39.9 average: 2ms
fps: 38.4 average: 2ms
fps: 38.3 average: 2ms
fps: 42.6 average: 2ms
fps: 41.3 average: 2ms
fps: 33.6 average: 2ms
fps: 14.9 average: 1ms  - stopped scrolling
fps: 14.9 average: 1ms
fps: 20 average: 1ms
fps: 25.7 average: 2ms
fps: 22.8 average: 2ms  - began scrolling
fps: 43.8 average: 2ms
fps: 41.6 average: 2ms
fps: 46.9 average: 2ms
fps: 38 average: 2ms
fps: 6.9 average: 3ms
fps: 26.6 average: 1ms
fps: 22.4 average: 1ms
fps: 48.9 average: 1ms
fps: 17.2 average: 1ms
fps: 8.8 average: 1ms   - stopped scrolling
fps: 25.7 average: 1ms
fps: 42.5 average: 1ms

Not sure whether this could be of any use, but here’s my settings:

{
	"theme": "Adaptive.sublime-theme",
	"font_size": 13,
	"fade_fold_buttons": true,
	"rulers": [75, 80],
	"translate_tabs_to_spaces": true,
	"caret_style": "smooth",
	"scroll_past_end": true,
	"draw_white_space": "all",
	"trim_trailing_white_space_on_save": "all",
	"trim_only_modified_white_space": false,
	"ensure_newline_at_eof_on_save": true,
	"default_line_ending": "unix",
	"drag_text": false,
	"show_tab_close_buttons_on_left": true,
	"hide_tab_scrolling_buttons": true,
	"hide_new_tab_button": true,
	"show_git_status_in_status_bar": false,
	"show_git_status": false,
	"ignored_packages":
	[
		"Vintage",
	],
}

Update: Disabling hardware acceleration makes it much more responsive…

Frame time exceeded 60hz: 4.064e+08ms
fps: 61 average: 3.99844e+08ms
Frame time exceeded 60hz: 4.064e+08ms

Those “Frame time exceeded” floods the log output, but when it prints the fps message, is always >= 60.

0 Likes

#24

Those frame times when using hardware acceleration show it’s rendering extremely quickly. Do you perhaps have a high-refresh-rate display? - currently animations are hard-coded to 60hz.

0 Likes