Sublime Forum

ST4: "trim trailing white space on save" does not work (build 4113, Win10 x64)


I’m using a fresh portable build 4113 on Windows 10 x64.

The "trim_trailing_white_space_on_save" setting has no effect. I’ve tried all the options: "all", "not_on_caret" and even true (just in case :slight_smile: )

Not sure this is related, but the Command Palette “Trim Trailing White Space” (which triggers trim_trailing_white_space) does work!

Also, I’ve tried ST3 and "trim_trailing_white_space_on_save": true works fine for me on build 3211.

Can anyone replicate and confirm the problem? Surprisingly, google knows nothing about it, so I would like to know if it’s just me or it’s a bug. Thanks.



ST4 introduced "trim_only_modified_white_space" which is enabled by default.

1 Like


I changed "trim_only_modified_white_space" to False and now everything works. Thanks a lot!

I think, it would be nice if this new feature would be mentioned as a comment to "trim_trailing_white_space_on_save", that is the latter has no effect unless blah-blah… It’s a bit confusing as it is right now, imho.