Sublime Forum

ST3 flickering on MacOS

#1

Hi,

For some reason, ST3 [3205] window is flickering when the computer (with a ST3 active session) is waken up. It does not always occur, I would say every other time. This is especially visible on an external HMDI 4K display or on the mac screen when it wakes up unplugged and ST3 used to be displayed on the external screen.

Resizing ST3 main window usually stops the flickering.

Any idea why ?

https://www.dropbox.com/s/14uzclv6jfo9dx8/st3_flash.mp4?dl=0

Thanks.

2 Likes

#2

Same here. Happens sometimes after coming out of sleep.

I’ve commented about it in https://github.com/SublimeTextIssues/Core/issues/2782 which might be related (seems those started happening around same time).

0 Likes

#3

Can confirm similar or related issue. On my machine (MacBook Pro touchbar 15 inch 2017 running 10.14.4) it only flickers as I hover over file names (acting like it updates the whole UI at once when trying to shade the file the mouse is over OnHoverOver) but also that resizing the window does fix it.

0 Likes

#4

Can also confirm that this is happening on my 4K display, connected to a 2018 MacBook Pro 15" running Mojave (10.14.4, Radeon Pro Vega 20 4 GB), using a HDMI to Thunderbolt 3 cable.

Re-sizing the Sublime 3 window, or restarting Sublime 3 fixes the problem.

0 Likes

#5

I too am experiencing this issue.
Sometimes I’ll have multiple windows open and only some of them experience the problem.

useful specs:
Sublime Text v 3.2.1 Build, 3207
macOS Mojave: 10.14.4 (18E226)
MacBook Pro (13-inch, 2017, Four Thunderbolt 3 Ports)
Intel Iris Plus Graphics 650 1536 MB

I had not realized that resizing would help. Appreciate that idea!
-Jeff

0 Likes

#6

You should upgrade to 10.14.5: Crash or Memory Leak on macOS Mojave 10.14.4?

0 Likes

#7

I see flickering in ST3 in mojave 10.14.5, fwiw.

0 Likes

#8

The problem is exactly the same with SublimeMerge BTW (stable, build 1116)

0 Likes

#9

I get this when I have ST3 running on an external monitor via HDMI on my 10.14.5 Mac. What I found was to put just part of the window on my laptop main screen (even just the edge of the frame…can’t even see it on my laptop) and the flickering stops. Technically, no idea why, but it works for me.

1 Like

#10

I can also reproduce:

  • Sublime Text.app Build 3207
  • 10.14.6 (18G84) (without the Mojave 10.14.6 Supplemental Update)
  • MacBook Pro (Retina, 13-inch, Early 2015)
    (Intel Iris Graphics 6100 1536 MB,
    Device ID: 0x162b, Revision ID: 0x0009)
  • on 2nd external monitor (right side) (connected via HDMI)
    DELL P2417H, 1080 x 1920 @ 60 Hz, 24 bit colour,
    rotation: 90 degrees

It occurs inconsistently, but I see it 2~5 times a week.
The workaround of moving the window to slightly overlap onto the laptop man display DOES work to fix the issue.

0 Likes

#11

For those seeing this issue with 10.14.5+, could you try it with the gpu_window_buffer setting set to false?

0 Likes

#12

On 10.14.6. Setting gpu_window_buffer to false solves the issue. (External 4k display)

0 Likes