Sublime Forum

ST 4171 completely stuck after opening


I updated to 4171 because one of my plugins was running into the “api not available” issue.

Sublime now gets stuck while/after loading plugins with a beachball of death (MacOS). No errors, I can just see it loading plugins (I tried uninstalling/deleting the last plugins that showed in the console, but that didn’t help).

I can start in safe mode, but can’t open my regular sessions. Help. :frowning:



Quick note: because I couldn’t add multiple images while posting. I did remove another package that I was suspecting and the editor now worked until Package Control decided to update it:

I’m going to try to get rid of this package completely somehow …



You can downgrade to a previous version by downloading 4168 from

We’re working on fixing this issue.



Thanks. It turns out it seems that “UnitTesting” is the broken package, once I removed it so that PackageControl didn’t reinstall it, ST is unstuck now.



I upgraded to 4172, which the release notes say has a fix for package deadlocking, but I was still seeing the hang-on-launch as well.

  11  api_helper::api_plugin_host_loaded_plugins(std::__1::vector<std::__1::pair<object_id, std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char>>>, std::__1::allocator<std::__1::pair<object_id, std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char>>>>> const&) + 496 (sublime_text + 784356) [0x1020fb7e4]
  11  bool wait_for_reply<int>(shm_bundle*, reply_entry*, int*) + 76 (sublime_text + 824936) [0x102105668]
  11  shm_read(shm_channel*, string_buffer*, int, long long) + 48 (sublime_text + 1109764) [0x10214af04]
  11  sem_wait + 8 (libsystem_kernel.dylib + 67892) [0x18a40f934]
 *11  ??? (kernel.release.t6000 + 31396) [0xfffffe0008533aa4]

I’m on macOS Sonoma 14.1.2. No hang when launched in Safe Mode. I downloaded 4169 and everything is fine again. If it would be helpful to determine which package(s) is/are at fault, I can try a binary search with 4172.

		"Case Conversion",
		"Color Highlight",
		"Decent Swift Syntax",
		"Dockerfile Syntax Highlighting",
		"Package Control",
		"Project Specific Syntax Settings",
		"Show Character Code",
		"Switch Window",
		"Tailwind CSS",
		"Typora Markdown App (OSX)",
		"Wrap Plus",

Build 4172 hangs on start-up / MacOS

I had the same lockup, until Build 4172 solved it (AUR). Thanks!