Sublime Forum

SSH stopped working after new Sublime Merge dev channel update


The title is already well-explanatory itself, I don’t know why, in the latest build (2041) of the dev channel, all my ssh repositories stopped working on Sublime Merge. Yet, if I try to push/pull something from the cli using the system git, everything works alright. This started happening after the last update. Any help is appreciated as Sublime Merge is pretty useful and I hope this doesn’t turn up as a big bummer… For the record I use Windows 10.

This is what I get:
" Permission denied (publickey).
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists."

1 Like


Hi @evilgecko,

My hunch is that this is a config issue.

Could you confirm whether you are using system or bundled Git with Sublime Merge?
You can check this via Preferences > Advanced > Git Binary.

Kind regards,
- Dylan



Hello Dylan,
I’ve been using the default bundled Git, but, with this issue, I tried also the system Git. Both are giving me the same error. Strange it doesn’t happen in the command line, if it was happening there it was more than likely an ssh misconfiguration. But since it’s only happening in Sublime Merge I’m confused. SM used to show me a prompt in order for allowing me to enter my SSH key passphrase and now it just goes straight up to that error…

1 Like


Getting the same exact issue, it’s fine in terminal but in Sublime Merge doesn’t work.

I also get the same issue in the latest stable when using my system installation of git, bundled works fine.



Hi all,

Thank you for reporting this issue.

I’ve been able to track down the source of the issue, and I am investigating a fix.

In the meantime, you can work around this issue by setting the SSH Path via Preferences > Advanced > SSH Path to your default SSH client path (most likely C:\Windows\System32\OpenSSH\ssh.exe on Windows).

Kind regards,
- Dylan



I’m still experiencing the issue, even though I’ve followed all the steps mentioned above. I’m using Windows, and got Git Bash to work without entering a password each time by typing:

$ ssh-add
Enter passphrase for /c/Users/.../id_rsa:
Identity added: /c/Users/.../id_rsa

$ ssh-add -l -E sha256
4096 SHA256:[SHA] /c/Users/.../id_rsa

$ git pull
Already up to date. // Does not ask for password anymore!

Now, I go to SublimeMerge, perform a pull, and it still asks for my password:

So I go to Preferences > Advanced > SSH Path to point to C:\Windows\System32\OpenSSH\ssh.exe, as outlined by @djohnston, and now the prompt looks different, but it still asks for my password every time:

It doesn’t matter whether I’m using bundled or system Git Binary option from advanced preferences. Is there anything else I need to do to solve this issue?



With Sublime Merge and Git for Windows on a Windows 10 box you might easily call different SSH instances depending on which tool you use to run git (CMD, SM, git-bash):

a) Windows builtin SSH
b) SSH from Git for Windows
c) SSH from Sublime Merge’s minimal git client

What I d to keep things sane is:

  1. Set Sublime Merge to use Git For Windows instead of its builtin one. (even deleted the shipped git folder)
  2. Add environment variable GIT_SSH=C:\WINDOWS\System32\OpenSSH\ssh.exe to make sure Git For Windows uses builtin SSH client.
  3. Open Services Management Console and set OpenSSH Authentication Agent to startup automatically. IIRC it does not by default.
  4. Make sure to restrict access permissions to your private key files. Otherwise Windows SSH agent will deny using them. Access may be granded to SYSTEM, Administrators and your own user account only.
  5. Run ssh-add to add the keys to Windows’ ssh agent.

I did so a while ago and don’t have any issues with Git over SSH at all.

1 Like


Oh man… thanks for the info. Although I don’t know how to perform 3/5 of the commands you listed above. I just can’t waste another afternoon on this, I can’t believe it takes so much effort to get it working. Not your fault, I appreciate the help, it’s just frustrating.



Hi @marquizzo,

Thanks for your patience while we address this regression.

We’ve added a workaround for the regression in OpenSSH, which will become available in the next development build. In the meantime if this issue is affecting you, I suggest uninstalling the development build, and installing the stable build of Sublime Merge instead.

Kind regards,
- Dylan

1 Like


Thanks for the update @djohnston!

I believe I made a mistake in posting on this thread, because my issue is that the stable build (2039) asks for the password each time I pull or push via SSH. I just re-read the top post, and their problem is that SSH stopped working altogether in the dev build. Not sure how I got confused, but maybe I should open a new thread with my issue instead of hijacking this one :slight_smile: