Sublime Forum

[solved] Sublime merge won't run code editor



I’ve been using sublime merge for some months and I was able to run my code editor from it without any issue.
Recently, I’ve purchased it, and switched the version from AUR to the provided Arch linux repo. (I’m not sure it is related)

Now the code editor isn’t launched by sublime merge (nothing happen)
I’ve tried removing the related settings, and it well launched sublime text 3.
Nothing appear in Console.

I’ve tried to run the command from a terminal and it work.

My settings :

	"editor_path": "/usr/bin/code",
	"editor_argument_format": "--goto ${file}:${line}:${col}",
	"hardware_acceleration": "opengl",
	"theme": "Merge Dark.sublime-theme",
	"side_bar_layout": "locations_as_column",


Does the console say anything? I can confirm it is working for me as expected on MacOS



Nothing appear in the smerge’s console



Ok, I’ve found the problem.
Since a recent sublime merge update (maybe 2020) I have to force GDK_BACKEND env var to “wayland” for have it launched within wayland and not x11. (It wasn’t needed before)
But, vscode is an electron app and, for now, it require x11. Thats why code won’t launch from smerge.
I’ve solved it by creating a little script to change GDK_BACKEND before launching code

GDK_BACKEND="x11" /usr/bin/code "$@"
1 Like